iOS Question Problem with Bridge and Debug

CryoGenID

Active Member
Licensed User
Longtime User
Hello everybody,

I am trying for hours now to get the basic setup working.
Using a Mac for the compilation and a Windows VM (using a bridged network) for the development.
I have followed the videos but the first problems arises when I try to install the bridge using Safari on the iPhone:
I get the website displayed perfectly fine, but when I click on the button "Install App", simply nothing happens. No error, nothing.
My next step was to use iTunes to deploy the IPA on the iPhone. That worked and I could see the designer when I opened the bridge app on the iPhone. I could design the "first app" perfectly fine.
But then I tried to debug (or start) the app.
When I pressed the "Play" button, the bridge was still running on the device. It then started compiling, and the compiler window told me to run the app on the device.
Here is the second problem:
On my device only the bridge app got closed automatically, nothing else happened. No info about if I wanted to install a program, nothing.
The same happens if I press "Play" when I don't have the bridge app open on the device.
The b4a-certificate is installed on the device.

Any help here?
I would really like to start coding (and debugging *g*) ;-)

Thanks and best regards,

Chris

---
Update:
Output of ../test of the server:
--
B4i Build Server
Build server is running.
Version: 1.5
Server time: 18:26:54
Mac SSL Key
Key IP: 192.168.100.159
SSL port: 51042
h files
  • iAd: 1.00
  • ...
--
 

CryoGenID

Active Member
Licensed User
Longtime User
Hello Erel,

done :)

But I cannot see any difference between the both files...
Regardless if I use automatic or manual IP, I get the "invalid key" error...
Using the automatic IP, everything works fine though (so the "invalid key" doesn't seem to make any problems)...

Thanks a lot and best regards,

Chris
 

Attachments

  • B4iBuildServer_AutoIP.html.txt
    3.1 KB · Views: 149
  • B4iBuildServer_ManualIP.html.txt
    3.1 KB · Views: 141
Upvote 0

CryoGenID

Active Member
Licensed User
Longtime User
Hello Erel,

thanks for your update.
It would be great if the problem could somehow be solved ;-)
As a "quick" solution, could you add the option to define which network device the server automatically uses (eth0, etc.)?
Perhaps with that trick we could get it to work :)

Thanks a lot and best regards,

Chris
 
Upvote 0

davepamn

Active Member
Licensed User
Longtime User
If I use manual, I can't create the keys.txt, through,java -jar b4ibuildserver.jar

However, if I remove the key.txt and the purge the key and don't use manual ip then automatic generate works. However I can't connect with the generated ip between the mac and ip.

I am stuck. I need to override the ip address. The keys.txt generates the wrong ip address for the mac. I need to be able to put manual in the key.txt

If I try to access the ip address from the safari browser on the iPad, it tells me the certificate is not trust for the ip address generated by macserver-aa

I can not receive a static ip address. So I don't understand how the macserver-aa is getting the ip address. Why doesn't the manual ip become trusted?
 
Last edited:
Upvote 0
Top