B4J Question Problem with Java Serial Connector Library from OpenJDK11

Discussion in 'B4J Questions' started by Didier9, May 11, 2019.

  1. Didier9

    Didier9 Active Member Licensed User

    Not a B4J issue proper, but an issue using it nevertheless...
    I installed B4J with OpenJDK11.
    I an getting this error when trying to open a COM port under Win 10 64:
    Code:
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  EXCEPTION_ACCESS_VIOLATION (
    0xc0000005) at pc=0x000000006a00b5bb, pid=3152, tid=5668
    #
    # JRE version: OpenJDK Runtime Environment (
    11.0.1+13) (build 11.0.1+13)
    # Java VM: OpenJDK 
    64-Bit Server VM (11.0.1+13, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
    # Problematic frame:
    # C  [jSSC-
    2.6_x86_64.dll+0xb5bb]
    #
    # No core dump will be written. Minidumps are 
    not enabled by default on client versions of Windows
    #
    # An error report 
    file with more information is saved as:
    # C:\Users\Owner\DOCUME~
    1\B4JPRO~1\R9_B4J\dev\Objects\hs_err_pid3152.log
    #
    If you would like to submit a bug report, please visit:
    #   http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine 
    in native code.
    # See problematic frame 
    for where to report the bug.
    #
    I googled it and found a number of references to this bug being due to an issue with the jssc library (as pointed out by the error log).

    I switched to the Oracle version of Java and the problem went away.

    It seems strange (and more than a little bit disappointing) that this particular issue has been reported for quite some time and that nobody has fixed it.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Version 8? or 11?
    If I remember correctly unmodified library will only work with Java 8 32 bit on Windows 10.
     
  3. Didier9

    Didier9 Active Member Licensed User

    I am using jdk1.8.0_152 at the moment, 64 bits (jdk-8u152-windows-x64.exe).
    Interestingly, I very occasionally get the same error with this one, but most of the time the program runs.
     
  4. Didier9

    Didier9 Active Member Licensed User

    The error occurs when I try to rapidly close then reopen the port, not every time. It may depend on whether there is data in the buffer or data coming in, I have not been able to troubleshoot further because it is now pretty rare and it is hard to control the data coming in.
     
    Last edited: May 12, 2019
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice