iOS Question Push Notifications - Almost there..

Discussion in 'iOS Questions' started by Darren69, Apr 27, 2015.

  1. Darren69

    Darren69 Member Licensed User

    Hello,

    I finally managed to make the stars align and got the Push demo working to send push notifications, Erel is right, a lot of patience is needed, the apple servers seems to like to not connect sometimes, and sometimes they do.

    Anyway, I now want to add push notifications to an existing application, which I thought would be really easy, but I have ran in to an issue.

    I edited the current app ID to add push notifications, created the new certificates (aps_development and aps_production) created the new provision profiles and dropped them all in to a new keys folder for the application I am working on (as I figured that these provisions and certificates are now not wild card and so needed to be used for this particular app I am working on)

    I also copied in to the same folder (just in case they were needed) the b4i.keystore, certSigningRequest.csr and the B4i.p12 file.

    I created a new Push.

    in my application set the #provisionfile: to me my new .mobileprovision file I got and tried setting the #CertificateFile: to be aps_development.cer file.

    when I try to run as a debug I get an error telling me the certificate file name must start with iOS so I added iOS_ to the front of the aps_development.cer file.

    when I try to compile now I get an error message which I think comes from Xcode.

    Code Sign Error: No code signing identities found that match the provisioning profile specified in your build settings were found.

    did I miss a step somewhere?

    I have tried starting from scratch with everything but deleting the app ID because I didn't know how that would effect the versions of the application I already have out there in testing with test flight.

    anyone have any insight as to what step I may have missed?

    when I looking Xcode I see the provisioning profile I set up for this application so its a little weird.

    thanks

    Darren
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    The aps_development.cer is the certificate used to create the server ssl key. You shouldn't rename it. Instead use a regular certificate.
     
  3. Darren69

    Darren69 Member Licensed User

    ok grabbed my regular certificate and get the same result.

    I decided (since the only thing I had not deleted and tried again) was to make a new App ID and get all the certificates and things again, and I still get the same error about no code signing identities found that match my provisioning profile specified in my build settings.

    where else should I start looking?
     
  4. Darren69

    Darren69 Member Licensed User

    Erel, is it worth me generating a new Private Key CertSigningRequest Certificate, and if I do, how would this effect apps I have already released to the store that are live, and when I come to update them?

    at the moment that is the only thing I have not tried, and the error message is the same about No Codesigning identities (i.e Certificate and private Key pairs) that match the provisioning profile specified in your push settings ("Push") were found.
     
  5. Darren69

    Darren69 Member Licensed User

    Update- I think maybe its a china thing, there is some weird stuff happening while i am here, but anyway, I recreated all my provision profiles and certificates (again) like I have done a few times today and now magically it works.

    Cant explain what I did differently, but now it works and compiles ok, wonder if it will be the same when I push to the App store.

    Darren
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice