iOS Question [SOLVED]Compile error

Jorgelcr

Active Member
Licensed User
Hello,

It's been days since I had to modify an app that I have for ios, today I modified a part of the code and when I tried to compile it gave me an error in the part of "sending data to the remote compiler". Just in case I have generated a signature again, download mobileprovision, certificate. But it keeps giving error.

I sell a gigantic list of lines, but in the first lines I see the following:


note: Using new build system
note: Using codesigning identity override:iPhone Distribution: Jzzz zzz (VXXXXXXXX)

Once the remote compiler had failed for some hour but it used to give a time out error.



Anyone know what can it be?

Thanks.
 
Last edited:

José J. Aguilar

Well-Known Member
Licensed User
Hi Jorge:

You should write in english in ths part of the forum. There's a specific forum in Spanish.
Anyway, probably someone will translate your message and will answer you, but if you want to get more help here, you should write in english.

Hola Jorge:
Me temo que en esta parte del foro hay que usar el inglés. Hay un foro específico en español.
Aunque probablemente alguien traducirá tu pregunta con google translate o similar, te podrá ayudar mucha más gente si escribes el asunto y tu pregunta en inglés.

saludos,
 

Jorgelcr

Active Member
Licensed User
Hi Jorge:

You should write in english in ths part of the forum. There's a specific forum in Spanish.
Anyway, probably someone will translate your message and will answer you, but if you want to get more help here, you should write in english.

Hola Jorge:
Me temo que en esta parte del foro hay que usar el inglés. Hay un foro específico en español.
Aunque probablemente alguien traducirá tu pregunta con google translate o similar, te podrá ayudar mucha más gente si escribes el asunto y tu pregunta en inglés.

saludos,
thanks ;)
 

Jorgelcr

Active Member
Licensed User
1. When have you created the certificate and provision profile?
2. Does it happen with both builders?
1- The certificate and provisioning had been created, but since it gave me an error I have created new ones.
2- I don't understand what you mean by both builders
 

Jorgelcr

Active Member
Licensed User
That was it, a whole day going crazy !!!!!
You can try to switch to the second builder (Tools - Build Server - Settings - Secondary). They are identical but in the last couple of days there were some strange issues so it is worth a try.
 

Jaume Guillem

Member
Licensed User
Jaume, I don't understand you, what do you mean?
I'm blocked with the same error. Same messages. I'm using local builder.
In my case it happens with certificates created today , and it works with old certificates. May be a problem with the new intermediate certificate?????
 

Jorgelcr

Active Member
Licensed User
my problem was the hosted builder. Once the secondary is marked it has worked without problems.
If the certificates give you an error, I suggest you do everything again: create keys, application id, certificate, and mobile provisioning
 

Jaume Guillem

Member
Licensed User
my problem was the hosted builder. Once the secondary is marked it has worked without problems.
If the certificates give you an error, I suggest you do everything again: create keys, application id, certificate, and mobile provisioning
I've already done it many times. However, with certificates from a few months ago, everything works fine. It is the certificate created yesterday and today the one that does not work. That is why I am suspicious of the intermediate certificate. Apple notice of what will be created from January 28 should use it, but I do not know how.
 

Jaume Guillem

Member
Licensed User
Finally the problem was the Apple's new intermediate certificate. With certificates and provision files made months ago, everything works normally, but with certificates created two or three days ago, it does not work, and it is because it is necessary to install the new Apple intermediate certificate (which expires in 2030) in the MAC certificate keychain, because NEW certificates are validated with this one. Once this is done, everything works normally.
 
Last edited:
Top