Android Question [SOLVED] - Problem to crete Android 9 (28) AVDs

IlCasti

Active Member
Licensed User
Hi guys,
I have some trouble creating this emulator to test my app.
Erel has released version 3.30 of the SDK Manager.
I tried to create the image, but when it runs after some minutes the home screen does not appear.
I use B4A vers. 8.5 and java jdk1.8.0_171
Thanks for your help.
IlCasti

Immagine.png Immagine.png
 

Erel

Administrator
Staff member
Licensed User
The versions of B4A and Java are not related. You should try to press on the home button or the power button. If not helps then create a new AVD.
 

IlCasti

Active Member
Licensed User
Built and removed much avds version.. try all x86_x64
Neither platform 28 google api and platform 28 google api playstore and default configuration works
Progressbar still running, home doesn't appear
Nothing of the way suggested works.
Any other tips? Which android components from sdk manager require?
Thank you.
 
Last edited:

IlCasti

Active Member
Licensed User
Tryed to remove everything about api livel 28, also emulator, and reinstall but no success..
Still looking for any solution
Thank you anyway
 

IlCasti

Active Member
Licensed User
I found a solution (maybe just for me.. i don't know) with the help of @fasilosman.

This is what @fasilosman wrote me:

I found the solution.
All what we need is an emulator with api/sdk vesion of 28.

According to this post
https://www.b4x.com/android/forum/t...ared-avds-from-others-ides.92014/#post-581420
I created an emulator in android studio - nexus 5 with sdk 28. It works.
Here are the steps I followed.

01. Install Android studio. (Installed all recommended components)
02. Open Android studio and click emulator button.
03. Create an emulator as you need and run it. (you need to download the required sdk version at this time)
04. Now open the B4A project -> IDE option -> increase the timout to 300.
05. Now here you go. run the project and enjoy.
and then what i do to work just with b4a:

Yeah!!! :)
It works launching android studio emulator and then running project from b4a debug.
Nice thought!

But i'd have liked to work only with b4a :rolleyes:...., so then:
01. I created avd 28 api from b4a avd manager "6in_Phone_Platform_28_google_apis_playstore"
02. I copied from Nexus_5_API_28.avd to 6in_Phone_Platform_28_google_apis_playstore path every file, except ini file, overwriting everything
03. start 6in_Phone_Platform_28_google_apis_playstore b4a emulator and "wow! it works!!!" It shows just randomly errors from services but app run without problem. So now i can work only with b4a. :cool:
I hope it can help someone else.
IlCasti
 

IlCasti

Active Member
Licensed User
Sorry, as @fasilosman pointed out to me, it is not necessary to copy any files because you will find them in the b4a avd list
I did cause i had some problems with my previously creation
So I thought it was a good idea to copy all the file

Now I have cleaned my disk and everything works fine without any additional copy
 

fasilosman

Active Member
Licensed User
Please note that, you should do the following in order to view the avd in b4a avd manager, which you created in android studio.

In the B4A SDK manager, download all recommended components of SDK version 28 and the same system image of the avd in android studio (better download all system images of SDK version 28) .

Then you will find the avd in the B4A avd manager list.
 
Top