1. *** New version of B4J is available ***
    B4J v7.8
    Dismiss Notice

Android Question sudden problem compiling code

Discussion in 'Android Questions' started by abarnett, Jul 31, 2019.

  1. abarnett

    abarnett Member Licensed User

    I have 2 almost identical android programs. 1 compiles fine but the other now does not.
    The error is
    src\b4a\iTrack\main.java:7466: error: package com.google.android.gms.maps does not exist
    mostCurrent._gextrad.SetTrafficEnabled((com.google.android.gms.maps.GoogleMap)(mostCurrent._gmapd.getObject()),anywheresoftware.b4a.keywords.Common.False);

    I added the barcode camera code(https://www.b4x.com/android/forum/threads/barcode-reader-based-on-google-play-services-vision.89705/) into this program and since then it will not compile. I have now taken this code out but still not compiling. I have cleaned project but still no luck. Any ideas where I should look.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

  3. abarnett

    abarnett Member Licensed User

    I have found that if I remove the RuntimePermissions (Version 1.10) from the program that does not compile then it is fine !!
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    Make sure that this line is included:
    Code:
    #AdditionalJar: com.google.android.gms:play-services-maps
     
  5. abarnett

    abarnett Member Licensed User

    Thanks. Found problem I had the #AdditionalJar commented out because I had this line in which works but obviously not with other library functions.
    '#AdditionalRes: C:\Program Files (x86)\Android\android-sdk\extras\google\google_play_services\libproject\google-play-services_lib\res, com.google.android.gms

    I have removed this specific line and added the #AdditionalJar line. This program now compiles fine even with the RuntimePermissions Library included

    Thank you Erel
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice