iOS Question udid.io secure connection

rfresh

Well-Known Member
Licensed User
Longtime User
I'm following Erel's tutorial on getting started with B4i and specifically the udid.io process of installing a profile. I cannot install the temporary profile because I get a msg saying the App Transport Security policy requires the use of a secure connection. What do I have to configure on my iPad to achieve this?

Thanks...
 

hatzisn

Well-Known Member
Licensed User
Longtime User
I am newbie too in B4i. It seems as I have read in the forums that the App Transport Security or ATS is a feature introduced in iOS 10+ (if I remember correctly) which forces the app to use only https://... (secure connections). Safari is ATS enabled and get.udid.io is only http://... . You can find it in B4i in the begginning of the project as ATSEnabled: True/False. Did you manage to install B4i bridge and connect to it correctly? I didn't manage to do so yet (it is installed but the IDE does not connect to the B4i bridge)...
 
Upvote 0

rfresh

Well-Known Member
Licensed User
Longtime User
Yes, I was able to install the bridge and get a test iOS project to connect to it and start up in debug mode.
 
Upvote 0

rfresh

Well-Known Member
Licensed User
Longtime User
I'm using an iPad. This morning I notice that the bridge isn't working correctly like it was yesterday. Yesterday it worked perfectly every time. This morning is isn't working and I have to take it out of memory and restart it. It's a hit and miss using it this morning. I'm not sure why.
 
Upvote 0

hatzisn

Well-Known Member
Licensed User
Longtime User
Looks like an epidemic. It might be contagious... :):):):):) You may have caught it from me...;) Which iPad do you use? And which iOS does it run on?

Edit - Wow!!! New skill for me. Homeopathy in logic. I am always impressed.
Edit 2 - I double the always impressed. Don't thank the opinion maker...
 
Last edited:
Upvote 0
Top