Android Question Uncaught translation error After Updating Android SDK

Kiran Raotole

Active Member
Licensed User
I follow this tutorial :: https://www.b4x.com/android/forum/threads/crashlytics-crash-reports.87510/

and Update Android SDK Because its showing ::
Maven artifact not found: com.google.firebase/firebase-components

After that Compiler Showing
B4X:
B4A Version: 9.80
Java Version: 8
Parsing code.    (0.00s)
Building folders structure.    (0.00s)
Compiling code.    (0.02s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (0.01s)
    (AndroidX SDK)
Generating R file.    (0.22s)
Compiling generated Java code.    (0.97s)
Convert byte code - optimized dex.    Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/internal/measurement/zzu;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/internal/measurement/zzv;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/internal/measurement/zzw;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement$ConditionalUserProperty;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement$Event;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement$EventInterceptor;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement$OnEventListener;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/google/android/gms/measurement/AppMeasurement$Param;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
    at com.android.dx.command.dexer.Main.processAllFiles(Main.java:692)
    at com.android.dx.command.dexer.Main.runMonoDex(Main.java:315)
    at com.android.dx.command.dexer.Main.runDx(Main.java:293)
    at com.android.dx.command.dexer.Main.main(Main.java:249)
    at com.android.dx.command.Main.main(Main.java:94)
Caused by: java.lang.InterruptedException: Too many errors
    at com.android.dx.command.dexer.Main.processAllFiles(Main.java:684)
    ... 4 more
Current SDK path :: E:\android_sdk\sdk\platforms\android-28\android.jar

Problem Occuring on this line :
#AdditionalJar: com.google.firebase:firebase-core
 
Last edited:
Top