Android Question What is required to create compatible Android 5 version:

johnerikson

Active Member
Licensed User
Android 5 have been sent to the Galaxy 4, resulting in many unidentified crashes.
That have creates problems for my users and for me!
What is required to create compatible versions:
Which SDK packages required (API 21)?
Can older API used?
I am familiar with (SetApplicationAttribute (android: theme, "@Android: style/Theme. Holo")
Identified is MSGBOX causes crashes!

I use B4A 4.0 on Windows 7.0. I have many apps created on earlier versions from 2.2 - 4.x
A step to step instructions to reach the Android 5 level is helpful, perhaps it already exist, in that case where?
 

NJDude

Expert
Licensed User
The reason of those crashes should show on the unfiltered logs, have you looked there?.

Regarding the "step by step" instructions, search the forums, there are plenty of posts, start by reading above under "SIMILAR THREADS".
 

johnerikson

Active Member
Licensed User
The problem is that the errors reported from users. I have now begun to try Android 5 and will analyze the issues.
Important is the question whether I need to update the Android sdk package to 5 (21) or not,
is it necessary?

I will come back later with errorlists if necessary!
 

NJDude

Expert
Licensed User
It is recommended that you always use the latest SDK release, however, this has no effect on the compiled code since it's the version on the device that will run the app, Android is backwards compatible.

To pinpoint the problem(s), you should get the logs as I mentioned above.
 
Top