B4A Library AppCompat - Make Material Design apps compatible with older Android versions

Discussion in 'Additional libraries, classes and official updates' started by corwin42, Dec 19, 2014.

  1. jayel

    jayel Active Member Licensed User

    hey,

    The same here, I update the library and i get following error when compiling :
    Any help?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread in the questions forum and if possible include a project that demonstrates the issue.
     
  3. R0BERT0

    R0BERT0 Member Licensed User

    Hello.
    I have a problem... I'm trying compile my old project, but i can't.
    When try compile the ide say me:

    Cannot find: C:\Program Files (x86)\Anywhere Software\Basic4android\libraries\com.android.support:appcompat-v7.jar

    how can i do?
    thanks.
     
  4. corwin42

    corwin42 Expert Licensed User

    You need to install Android support repository with the Android sdk manager.

    Edit: Which B4A version are you using? This error sounds like you use a B4A version prior to 6.0.
     
    R0BERT0 likes this.
  5. R0BERT0

    R0BERT0 Member Licensed User

    Hello corwin, thanks for reply.

    I have android installed Android support repository, rev 44

    My b4a is v5.2
     
  6. corwin42

    corwin42 Expert Licensed User

    See the first post. You need at least B4A 6.0.
     
  7. R0BERT0

    R0BERT0 Member Licensed User

    But... i use this library in the past with my b4a version...

    Can you pass me the old library please?
    Thanks.
     
  8. R0BERT0

    R0BERT0 Member Licensed User

    Please sir... i need update my app quickly.

    I'm not sure if i update b4a another library not work.. please is very urgent to me.
    Thanks.
     
  9. corwin42

    corwin42 Expert Licensed User

    I highly recommend to update to the latest B4A version and AppCompat version.

    There is no current support library version as a jar file anymore. Google switched over to the maven repositories which can only be used with B4A 6.0 and above. B4A 5.2 is more than 1.5 years old. It is time to update.

    I sent you the 2.0 AppCompat library by PM. Be aware that I can't give any support for such an old version anymore.
     
    Erel and DonManfred like this.
  10. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread for this question.
     
  11. Croïd

    Croïd Active Member Licensed User

    If i delete all sdk except 23.0.3 it works fine ! but I need sdk 25 and 26 for different project !

    What is the solution to be able to preserve the others Build-Tools in the folder ?

    Thanks for reply
     
  12. corwin42

    corwin42 Expert Licensed User

    Read the install instructions. You can and should use build tools 25 x.x
     
    Croïd, DonManfred and Erel like this.
  13. Erel

    Erel Administrator Staff Member Licensed User

    Croïd likes this.
  14. victormedranop

    victormedranop Well-Known Member Licensed User

    hi. I am trying to use appcompat. but no mater what example I use I got this error.
    I change the build-tool to 25, please some help.

    C:\Users\victo\Desktop\AppCompatBase\Objects\bin\extra\res2\res\values-v23\values-v23.xml:4: error: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'.
     
  15. DonManfred

    DonManfred Expert Licensed User

    Use a newer Version of Android i would suggest.
    You need platforms/android-23/android.jar or higher

    If that does not help then i suggest to create a new thread in the questionsforum giving us enough details to help.
     
    Peter Simpson likes this.
  16. Urishev

    Urishev Member Licensed User

    Thank you corwin42 for the detailed explanation. I have b4a 5.5.
    I stopped at first item. Where and how to download files AppCompat.aar ? Where to get V3.51 of this library?
     
    Last edited: Aug 15, 2017
  17. DonManfred

    DonManfred Expert Licensed User

    Post #1!!!
     
  18. Urishev

    Urishev Member Licensed User

    Please give an answer.
    Is it possible to use AppCompat library to B4A less than 6.0 (with modifications) or it is absolutely impossible?
     
  19. Erel

    Erel Administrator Staff Member Licensed User

    As far as I know, you must use B4A v6+.
     
    corwin42 likes this.
  20. corwin42

    corwin42 Expert Licensed User

    Since AppCompat is provided as an AAR library you will need B4A 6.0 or above.
     
    lemonisdead and DonManfred like this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice