Android Question B4A is quite slow on computer with Intel Atom

Edgardo PuntoCom

Member
Licensed User
B4A is quite slow on computer with Intel Atom Processor Z3735E (2M Cache, up to 1.83 GHz)

I am sorry. I did not explain well . The problem is that it takes a lot to spend the next step when compiling:
Convert byte code - optimized dex.

sometimes it does in 30 to 50 seconds but sometimes fails to compile.

Computer is: Intel Atom Processor QuadCore Z3735E (2M Cache, up to 1.83 GHz), 2GB RAM

This is normal?
Can I improve it in some way ?
 
Last edited:

Edgardo PuntoCom

Member
Licensed User
I am sorry. I did not explain well . The problem is that it takes a lot to spend the next step when compiling:
Convert byte code - optimized dex.

sometimes it does in 30 to 50 seconds but sometimes fails to compile.

Computer is: Intel Atom Processor QuadCore Z3735E (2M Cache, up to 1.83 GHz), 2GB RAM
 
Upvote 0

Erel

Administrator
Staff member
Licensed User
This is normal. The dexing step (which is done by Android SDK) is relatively heavy. Increasing the memory by changing MaxRamForDex can help but your computer is very low on memory.

You can increase the timeout limit under Tools - IDE options. You can also disable the optimized dexer if you see that it mostly fails.
 
Upvote 0

Cableguy

Expert
Licensed User
I have a T100 transformer from Asus, same base as yours, and I usually compile (complete with device deployment) under 15s... the most heavy I had was under 1m, and all I did was increase the timeout!
Also, compiling from remote locations can give results like the ones you have
 
Upvote 0

Edgardo PuntoCom

Member
Licensed User
This is normal. The dexing step (which is done by Android SDK) is relatively heavy. Increasing the memory by changing MaxRamForDex can help but your computer is very low on memory.

You can increase the timeout limit under Tools - IDE options. You can also disable the optimized dexer if you see that it mostly fails.
That's right, has already 1GB RAM in MaxRamForDex and if I increase fails. That error is due to the low RAM.

Thanks for the suggestions. I'll try what everybody have recommended me but before I will restore the PC to cleanse the system.
 
Last edited:
Upvote 0

techknight

Well-Known Member
Licensed User
2GB of RAM is puke these days for PCs. 4GB I feel is the lowest limit. 16GB being the most spacious/comfortable, with 8GB being recommended under most conditions. 2GB is just not enough. Almost like trying to run 128MB on a fully updated windows XP install.
 
Upvote 0
Top