Android Question .BAL file not loading

Discussion in 'Android Questions' started by Rogerardo, Aug 8, 2019.

  1. Rogerardo

    Rogerardo Member Licensed User

    New application will not run. Screen seems to be bring picked up from wrong location.
    I have just upgraded to the latest version. Created a very simple project (all it does is display a simple screen)
    When I try to run, the .bal file seems to be trying to load from /data/user/0/RY.ScreenSizer/files/virtual_assets/screensizer.bal.
    How do I change this location? What should the location be?
    All I have done is create a new project and a screen and tried to run it.
    The only code in the project is
    Activity.LoadLayout("ScreenSizer")
     
  2. klaus

    klaus Expert Licensed User

    How did you generate the ScreenSizer.bal file?
    It should be in the Files folder of your project.
    When you define a layout in the Designer it is automatically saved in the projects Files folder.
     
  3. Rogerardo

    Rogerardo Member Licensed User

    All I did to generate the .bal file was to go into the designer, create a simple screen, then save it. It is in the "Files" folder of the application.
    I am just a little frustrated. I had no issues with the previous version. I upgraded to the latest due to my main application not running properly on Samsung Galaxy TabA tablets. All appeared OK until I encountered this problem. My main appliocation still works (though still not on TabA's). It appears to me that the .Bal file is being picked up from a folder other than the applications own Files folder but I cannot find where this is configured.
     
  4. Erel

    Erel Administrator Staff Member Licensed User

  5. Shelby

    Shelby Active Member Licensed User

    You might try removing the file in your file folder of your project with that remove button at the bottom area, then use the Add Files button to replace it from where you store all your app files. I have tried this before for a successful remedy.
     
  6. Rogerardo

    Rogerardo Member Licensed User

    I already have the latest SDK.
    I removed the file, deleted it, recreated it and it now works.
    Thankyou
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice