Bug? Compilation error with rel 4.00

priusfan

Member
Licensed User
Bonjour et Bonne Année
On a project, when compiling with b4a rel 4.0, I get an error message:
B4X:
Parsing code.                           0.23
Compiling code.                         0.27
Compiling layouts code.                 0.03
Generating R file.                      0.14
Compiling generated Java code.          Error
B4A line: 133
points.Add(llPoint)
javac 1.7.0_55
src\emobility\canion\maps.java:893: error: cannot access LatLng
_points.Add((Object)(_llpoint.getObject()));
                                       ^
  class file for com.google.android.gms.maps.model.LatLng not found
Using rel 3.82, everything is OK. I am using the same libraries with both.

I will send to Erel the full project and the libraries I am using for diagnosis.
 

priusfan

Member
Licensed User
I have no need for additional res.
The config for the additional libs is the same...

Today, I updated the java JDK to 8 (from 7)...
I updated the paths in b4a to use the new jdk

My first test using the 32bits rel gave a problem with the memoryheap (not enough mem on a 16Gig W7...)

Never mind, I tested the 64 bits rel (I know it is not recommended):
it works perfectly with b4a V3.82, but I get the same error with V4.00.
 

Taha

Member
Licensed User
Dear Erel,

Upgraded to v4.00, thanks. Frankly speaking, before I updated my Windows as well. When running my old projects got error while compiling. Downloaded SPSpinner from the forum and tried to run - the same happens.

Tried both Java 7 and 8 (both 32-bit).

Please, support.

B4X:
Parsing code.                           0.03
Compiling code.                         0.08
Compiling layouts code.                 0.19
Generating R file.                      0.06
Compiling debugger engine code.         Error
javac 1.8.0_25
shell\src\com\stevel05\SLSpinner\main.java:51: error: constructor PCBA in class PCBA cannot be applied to given types;
        pcBA = new PCBA(this, main.class);
               ^
  required: Object,Class<?>,RemoteObject
  found: main,Class<main>
  reason: actual and formal argument lists differ in length
1 error
 
Top