Android Question Conflicting Signature

Discussion in 'Android Questions' started by nibbo, Sep 21, 2016.

  1. nibbo

    nibbo Active Member Licensed User

    Hi

    Think this is may be related to the latest version but not certain.

    I have updated my app and recompiled it in release mode but when the new version tries to install I get the error "An existing package by the same name with a conflicting signature is already installed".

    I appreciate I can simply delete the installed version and then install the latest but this will remove all existing database data leading to potentially losing important data (sales orders!!) not to mention several GB of images which will all need to be downloaded again by each user making it impractical.

    What does this message mean? I think it could refer to the 'Private signed key' which is all set to unknown in the settings and I don't recall ever setting up anything in there.

    Anyone got any ideas?

    Thanks
     
  2. DonManfred

    DonManfred Expert Licensed User

    You have compiled the two apps with a different keystore?
     
    lemonisdead likes this.
  3. DonManfred

    DonManfred Expert Licensed User

    Yes, this is related to the private signature key
    You need to use an own key.
    Search the forum about to setup the key
     
    lemonisdead likes this.
  4. fixit30

    fixit30 Active Member Licensed User

    In B4A v6.3 the debug signing key has been changed.

    You can use the old debug.keystore file from v6 without any issue
     
  5. nibbo

    nibbo Active Member Licensed User

    Thanks for this. Where can I download V6 from though? Mine has been overwritten by the latest install.
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    The old debug key is attached. You can copy it to B4A installation folder (replace the existing one).
     

    Attached Files:

  7. nibbo

    nibbo Active Member Licensed User

    Thanks Erel that seems to have fixed it. Better keep this file in a safe place.
     
  8. doncx

    doncx Member Licensed User

    Thank goodness I found this. The old key allows me to compile an update-able version to an app that's been in the field for a few years.

    Question: If the old debug key works just as well, why was it changed? Will I ever want or need to compile with the new (v630) debug key?
     
  9. Erel

    Erel Administrator Staff Member Licensed User

    It is a debug key. You should have used a private key for your app instead.

    It was changed because an antivirus software decided that this key is dangerous.

    No.
     
    Peter Simpson likes this.
  10. doncx

    doncx Member Licensed User

    Thanks for the explanation, Erel. I now understand. In my considerable ignorance, I did not know the role of debug (and other) keys.
     
  11. Smee

    Smee Well-Known Member Licensed User

    I have a similar message \ problem. However I did have a private key. I loaded it into the project successfully but i still get the error. How can I fix this? I upgrade from 4.x to 7.x

    UPDATE:

    Ok now i really have a problem. I have gone back to the earlier version of B4A and loaded the private key. I tried installing the new version so that i could export my database etc but i get the same error.
    Where do I go from here?
     
    Last edited: May 30, 2017
  12. DonManfred

    DonManfred Expert Licensed User

    You ALWAYS should create a NEW THREAD in the QUESTIONS FORUM. FOR EVERY QUESTION.

    Pushing old Threads is the wrong way to search for help. This applies to all your posts today
     
    Star-Dust likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice