iOS Question Error: security: SecKeychainItemImport: MAC verification failed during PKCS12 import (wrong password?)


Licensed User
i have been getting this error for a week. I have followed all of the threads on the forum. This problem does not seem to go away. I guess the question is where is the original password set. I do not recall ever setting it in the first place and have used the default for years. i did have an error a while back where there wasn't a password in the private sign key dialog box, but i added the default and things came back to normal.

there must be a password being held on the Mac, because that is where the java app logs the error, but i have no idea what it is actually being compared to or how it was set.

Thanks in advance,


Licensed User

first deleted existing cert and provision
Deleted existing c:\b4i\keys content
went to private key sign dialog, leaving the default password
3 files added
return to apple web site
created ios app developmet cert using cert request from keys directory
downloaded it to keys directory
created IOS provisioning profile
downloaded to keys directory
total of 5 files now

closed b4i
restarted b4i
went to tools...Build release app


i get the same result if i start with an ios distribution cert. I have repeated this process many times.


  • 1714339686398.png
    33.6 KB · Views: 17
Upvote 0


Well-Known Member
Licensed User
Longtime User
Upvote 0


Licensed User
Reinstalled jdk-14.0.2 from the Oracle archive, completely repeated the process, and it worked.
14.0.1 did NOT work, it hung when it created the cert. Thanks again for your help.:)
Upvote 0