iOS Question [Solved] B4i Configuration - App ID (wildcard)

Discussion in 'iOS Questions' started by Lori Scott, Nov 8, 2018 at 6:40 PM.

  1. Lori Scott

    Lori Scott Member Licensed User

    Getting started with B4i... Following the tutorial "B4i Certificate and Provision File", I tried to set up an App ID with an App ID description name 'All' and a Wildcard Bundle ID of *. However, it would not accept the Bundle ID of * wildcardError.PNG . It recommends a reverse domain ending with * so I used my company domain, reversed and ending in *. My guess then is that when I name a package later, I will need to include the reverse domain in the package name.

    Proceeding through the steps of the tutorial, all seemed to be going well. However when I reached the point in the next tutorial, "B4i-Bridge", of renaming my package in a new B4i project, I received an error message "Invalid package name". My company domain name has a hyphen in it so I thought this or the extra '.' in the name might be causing the error, so I went back and created a different App ID without any . or - in the ID. I repeated the other steps in the tutorial (create Production Certificate, create Provision File). When I used the new bundle ID followed by other text in place of the * in renaming a package, I did not get a package naming error message. However when I proceeded to build the B4i Bridge, the build failed and sent this error message:

    === BUILD TARGET B4iProject OF PROJECT B4iProject WITH CONFIGURATION Release ===
    Check dependencies
    Code Signing Error: Provisioning profile "Default" has app ID "comMTS*", which does not match the bundle ID "b4i.comMTSexample1.bridge".
    Code Signing Error: Code signing is required for product type 'Application' in SDK 'iOS 11.2'
    Error: ** BUILD FAILED **
    The following build commands failed:
    Check dependencies
    (1 failure)

    I tried again using a bundle ID of comMTS.* resulting in a similar code signing error and build failure. Can you please recommend how I can proceed to build the B4i bridge given that Apple is not allowing a bundle ID of *?
     
  2. Yvon Steinthal

    Yvon Steinthal Active Member Licensed User

    Basically you need something in that form:

    com.domainname.* for your certificate or how i use it: com.companyname.*

    In the IDE you can later then specify the wildcard like this : com.companyname.appname

    That way you dont need different certificates for different apps you are making.

    Don't know if it makes things clearer...
     
    Lori Scott likes this.
  3. Lori Scott

    Lori Scott Member Licensed User

    Yvon,
    Attempting to do as you've suggested:

    In Apple Developer Certifications..
    upload_2018-11-8_13-20-23.png

    In B4i Project>Build configurations...
    upload_2018-11-8_13-22-3.png

    In B4i Tools>Build Server>Build B4i Bridge App
    upload_2018-11-8_13-25-13.png

    Do I need to make the wildcard bundle ID b4i.com.MicroTrak.* to make this work?

    Lori
     
  4. Lori Scott

    Lori Scott Member Licensed User

    I tried using a bundle ID of b4i.com.MicroTrak.* and now the build of the the b4i bridge appears to complete successfully.
     
  5. Yvon Steinthal

    Yvon Steinthal Active Member Licensed User

    The example you used you didnt specify "b4i." in your apple certificate
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice