Android Tutorial B4A-Bridge a new way to connect to your device

Discussion in 'Tutorials & Examples' started by Erel, Feb 24, 2011.

Thread Status:
Not open for further replies.
  1. micro

    micro Well-Known Member Licensed User

    the device does not have a storage card.
    After I look at the log....
    but where do I find the log error?
    Thanks
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    B4A-Bridge requires a writable storage card. It is not possible to install programs that are saved in the internal storage.

    There are several apps in the market that allow you to see the logs.
     
  3. optimist

    optimist Member Licensed User

    Hello,
    i have a small issue to.

    B4A Bridge is so brilliant, that i can use thetering and bridge at the same time.
    It works! :icon_clap:

    But B4A Bridge shows the external ip-adress, gotten from the internet provider. This is an mistake. It shold show its ip from the internal (thetering) network.

    Greetings from germany
     
  4. r2d4

    r2d4 Member Licensed User

    Hello :)

    I got a problem with the connection, this is what I did:

    Installed B4A-Bridge into my Samsung S2 via Android Market.
    Enabled USB debugging in settings (S2)
    Connected S2 with my PC via USB
    Opened B4A Bridge (S2) and clicked connect
    Opened B4A IDE and tried to connect

    The IDE displayed at the bottom B4A-Bridge: Disconnected.

    What keeps my wondering the IP B4A-Bridger shows is a: 10.87.183.*** and my internal network is a: 192.168.2.*** network.

    How can I connect to my S2?


    Edit: I read now: "B4A-Bridge requires a writable storage card." - I got only my device storage, is that the problem?

    Thanks
    r2d4
     
    Last edited: Mar 10, 2012
  5. Erel

    Erel Administrator Staff Member Licensed User

    Try to use your internal network IP instead the one that is displayed.
     
  6. r2d4

    r2d4 Member Licensed User

    Hello,

    I tried the IP which my PC is using. But I can still not connect :sign0013:
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    The problem might be related to a firewall issue.

    Samsung S2 should support USB debugging. Installing the driver can be quite annoying however eventually it will work.
     
  8. r2d4

    r2d4 Member Licensed User

    I have already disabled my firewall for testing. But no change :(
     
  9. pamoxi

    pamoxi Member Licensed User

    Problem with compiled app

    I connect the program with the b4a Server in the tablet and work perfectly in edition mode, but when I compile the app, show the next error, after the compile process:

    "Installation will fail if the signing key is different than the previous used key.
    In that case you will need to manually uninstall the existing application."

    The device haven´t any app instaled. I have compiled the app in the emulator, but never in the device.

    What I have to do?
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    This message always appears. It just tells you that if the installation fails you should try to uninstall the existing app (if such exists).
     
  11. Erel

    Erel Administrator Staff Member Licensed User

    @r2d4 the next version will support B4A-Bridge over Bluetooth. Hopefully this will allow you to use B4A-Bridge.
     
  12. Andyroid

    Andyroid New Member Licensed User

    10.* addresses are usually dished out by the phone dats network. Is 3G connected?

    Sent from my GT-I9100 using Tapatalk
     
  13. RFI Bill

    RFI Bill Member Licensed User

    Erel the Bluetooth is a great added feature to the Bridge - many thanks.
    Would you please upload the latest source code to the Bridge as I could only find the old bridge code without the bluetooth. My wish is to study the bluetooth code. Thanks again.
     
    Last edited: Mar 30, 2012
  14. Erel

    Erel Administrator Staff Member Licensed User

  15. RFI Bill

    RFI Bill Member Licensed User

    Thanks Erel - I find the Bluetooth connection better than the WiFi; though it could be my setup.
     
  16. Amd97

    Amd97 New Member

    IDE Error

    Hey,
    Iam new and just downloaded B4A.
    Iam trying to connect my device to the IDE.
    I followed the steps exactly but when i clicked "Connect Bluetooth" it just freezes and i have to close it. And when i click "connect Wireless" it doesnt connect. Ihave lanched the B4A-Bridge app in my device.

    please reply ASAP.:)


    Thanks Alot.
    Ahmed.:D
     
  17. Erel

    Erel Administrator Staff Member Licensed User

    Seems like your Bluetooth driver is not supported by Basic4android.

    About the wireless connection, have you pressed on the Start wireless button on the device?

    Try to ping the device IP address from the computer.
     
  18. vb1992

    vb1992 Well-Known Member Licensed User


    Make sure you don't have USB cable connected to the device
    when you are first initially running the B4A-BRIDGE app
     
  19. imgsimonebiliato

    imgsimonebiliato Well-Known Member Licensed User

    Hello,
    is there a way to run the application without install it any time?
    In b4a I start the application on debug mode, but any time I have to install it.
     
  20. Erel

    Erel Administrator Staff Member Licensed User

    It is not possible to silently install applications in Android. It is only possible when installing in USB debug mode.
     
Thread Status:
Not open for further replies.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice