B4A-Bridge - Wireless problem

Tom Law

Active Member
Licensed User
Longtime User
I have been developing successfully with Basic4android for several months now with my tablet connected using the B4a-bridge program. After recently upgrading to the new Basic4android version (1.9) and upgrading the bridge to version 2.00 I have been unable to connect my Android tablet (Motorola Xoom) to either of my PC's.

The tablet connects fine to the home network and wifi works no problem. When starting up B4A-Bridge it seems to start normally (press on start to listen for connections). I click start-wireless and it displays 'Waiting for wireless connections'. Unfortunately thats as far as it gets.

Can I ask if anyone else is having a problem with the bridge or whether there is something that I need to do to re-establish connection.

Tom
 

LA3QMA

Member
Licensed User
Longtime User
b4bridge fails

Yes i have lotz of problem with my GalaxyTab 10.1 after upgrading.
My Motorola defy or whatever it's called do not have this problem.

But i only have problems when compiling and send the fiel to my device.
Disconnecting the "designer" first then i don't get the error.
 
Upvote 0

Tom Law

Active Member
Licensed User
Longtime User
Thanks for your reply LA3QMA however my connection will not work even under those limited circumstances. I can only surmise that there is something wrong with my Windows settings (I have tried turning off the firewall). Has anyone had any experience with fixing this type of problem
 
Upvote 0

Theera

Well-Known Member
Licensed User
Longtime User
Thanks for your reply LA3QMA however my connection will not work even under those limited circumstances. I can only surmise that there is something wrong with my Windows settings (I have tried turning off the firewall). Has anyone had any experience with fixing this type of problem

Hi all,
I tried install my app via B4A-Bridge. I coded by version 1.9 and use B4A-Bridge version 2.00 but I use the chinese tablet is not problem while installation. (run on windows7)

Best Regards
Theera
 
Upvote 0

Tom Law

Active Member
Licensed User
Longtime User
Hi Erel,

There was no error message - I suspect that the fault is probably with Windows rather than B4A. I would have expected a lot more replies if others had experienced an update problem. Could you possibly suggest which area of Windows would likely affect your program.

Tom
 
Upvote 0

Tom Law

Active Member
Licensed User
Longtime User
Hi Erel,

Thank you for your suggestion. Must confess I'm not totally sure if I'm doing this right but here goes.

1) From Windows 7 - I opened up a DOS box and issued the command Ping 192.168.0.2 (this is the IP shown on B4A-Bridge.

2) The reply back referred to a slightly different IP address (see below)

Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.3: Destination host unreachable.
Reply from 192.168.0.3: Destination host unreachable.
Reply from 192.168.0.3: Destination host unreachable.
Reply from 192.168.0.3: Destination host unreachable.

Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 4,Lost = 0 (0% loss),

Does this shed any light on the problem?

Thanks for your help.


Tom
 
Upvote 0

Tom Law

Active Member
Licensed User
Longtime User
SORTED - Thank you for narrowing it down Erel - turned out it 'was' a network error caused by my wireless modem. Turned it off for a few seconds, rebooted and it all worked. Must have just been coincidental that this happened at the time I upgraded the program.

:sign0142:
 
Upvote 0

DavidGolden

New Member
Licensed User
Longtime User
The wireless part of B4A-Bridge didn't change in the new version.

You can try to install the previous version of B4A-Bridge. First uninstall B4A-Bridge and then download and install the previous version:
www.basic4ppc.com/android/files/b4a_bridge1.apk


This tip, to run the previous version, was a life-saver for me -- running Nexus 7 tablet, Android 4.2.2.
When I ran the current version of B4A-Bridge, only the STOP button was live, hence forced to try earlier version.
 
Upvote 0
Top