Bug? B4A Designer keeps installing over and over


Licensed User
For some reason, all of a sudden, the Bridge wants to install B4A Designer over and over again. I have no idea why, I haven't updated any versions of B4A, Bridge or anything like that recently. I'm on the latest versions.

I can very easily trigger this in four ways:
  1. In IDE disconnect phone, then connect phone -> Bridge instantly wants to install Designer

  2. In Bridge STOP, then START -> Bridge instantly wants to install Designer

  3. In IDE trying to run the app -> Bridge wants to install Designer some time during compilation
    (this also silently fails the install of the app on the mobile)

  4. Not doing anything -> after a while Bridge wants to install Designer

I imagine 3 and 4 are actually the same.

Things I've tried that made no change:
  • Force-quitting the Bridge on the mobile
  • Force-quitting the Designer on the mobile
  • Uninstalling the Designer on the mobile
  • Restarted the IDE
  • Clean project

Any ideas on how to fix this?


Licensed User
I should add that it installs successfully (at least it claims so) and then:
  1. It presents the standard option to Open the app.
    (It makes no difference if I open or not, but I can successfully open it.)

  2. After ~10 seconds it pops open a new request to install an update.

  3. Installing that update is successful (at least it claims so).

  4. Goto 1 until you quit Bridge.

(Nothing changes if I decline the installation of the update. A new requests pops up shortly anyway.)


Licensed User
B4A: 7.30
B4A Designer: 7.30

Probably isn't relevant, but also:
Nexus 5X with 8.0.0 (and Nov 5th security patch level)

(Since my last post I also tried "Clear Cache" and "Clear Data" for Bridge. Neither made any difference.)


Licensed User
I expected it to be quite complicated to run your code. I can barely install my own app with all this re-installation going on - I have to time my install to happen somewhere between the Designer installs. To my surprise no request for Designer came as I started the Bridge this time.

This is the output from your code, is it the expected version?
version: 21

I am seriously confused. What in the world could cause something like this to appear, and then disappear?

(I also remembered that I have some UDP issue at my network that I never managed to solve. Here's the link to that thread. Probably has nothing to do with this, but thought it was worth mentioning.)


Licensed User
Yes, it works fine now. I can't trigger it in any way, starting/stopping Bridge, connecting/disconnecting IDE, leaving it alone - nothing seems to trigger this now.

I suppose we close this one and just hope it never happens again? Or do you want me to run some more tests for you?

And just for the record, here is a list of semi-notable things that I did not do.
(Might be helpful if somebody else gets this problem in the future)
  • Restart the phone
  • Restart the computer
  • Restart the router
  • Reinstall Bridge