Android Question B4A reinstall and Ok and error

AnandGupta

Expert
Licensed User
Longtime User
Well , thanks to 'Booklets' of Klaus and 'Video Tutorial' of Erel, I was able to install B4A 8.30 smoothly.
I already had earlier installation, which I uninstalled including Java.

The first test code ran successful in wifi connected b4a bridge in real device (Redmi 4).

After I close B4A and worked on other projects, I started B4A on same project and it gave error "The system cannot find the file specified"

Searching the forum I understood that I have to re-install B4A. My query is : Do I have to uninstall all i.e. B4a, Java, Android (tools) and reinstall all (it took rather very long time in my Win10 64 bit) or only B4A re-install will do ?

Any other short-cut method ? As I understand that the problem is created by Win updates more likely.

I have attached the project here, in case, any mistake in code.

B4X:
B4A Version: 8.30
Parsing code.    (0.00s)
Compiling code.    (0.10s)
Compiling layouts code.    (0.02s)
Organizing libraries.    (0.00s)
Generating R file.    (1.40s)
Compiling generated Java code.    (2.63s)
Convert byte code - optimized dex.    (3.29s)
Packaging files.    (0.32s)
Copying libraries resources    (0.04s)
Signing package file (debug key).    (1.04s)
ZipAlign file.    (0.21s)
Installing file to device.    Error
The system cannot find the file specified

Regards,

Anand
 

Attachments

  • Love_Test.zip
    401.6 KB · Views: 240

DonManfred

Expert
Licensed User
Longtime User
You can find the Setup-Instructions here. https://www.b4x.com/b4a.html
You also can watch this Video as it describes it clearly.

Start with a new Blank folder for the SDK like you see in the Video.
 
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
Thanks DonManfred for suggestion, but looks like I was not clear in my message.

Not only I studied Erel's video, I also studied Klaus's booklet, (see my original message). They guided me on new installation.
Not only I installed in new folder, I installed in new drive.

I was just wondering if I have to again re-install B4A, Java and all OR just B4A.

EDIT: I re-installed B4A over itself. No luck. Same error message. Looks like I will have to uninstall all and re-install all. :(


Regards,

Anand
 
Last edited:
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
This is the code as per Erel' video guide. (The code is attached in first post)

2018-09-05_013324.png

Can you guide why I am getting the error ?
Connection is Ok.

Is again clean re-install all the only option ?

Regards,

Anand
 
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
The project was saved in E: drive and B4A installed in C: drive.
Taking cue from your query, I made new folder in C: drive and saved new project from B4A in it.
Bridge connection was Ok. Still same error.

Clipboard01.jpg

Regards,

Anand
 
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
Yes, it is there in both drive folders,

2018-09-07_002508.png

I have also attached the full project folder, in case that helps. See if any solution can be found from it, else do not worry.

If I have to re-uninstall and re-install all I will do it next weekend as I have urgent projects now. I also got 8.50 beta, so will install that version.

Regards,

Anand
 

Attachments

  • Test1.zip
    401.2 KB · Views: 218
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
Yes, it did worked first time, that's why I wrote 'Ok' in subject line.
But after that it always giving 'device' error.
I have planned to do clean install again with 8.5 now after next weekend.

And Klaus, thanks a lot for writing the Booklets. The latest one is the best with separate folders and sample codes. If I can not make apps after reading it then I sure am not bright :) It is so much helpful for beginners. Thanks again.

Regards,

Anand
 
Upvote 0

AnandGupta

Expert
Licensed User
Longtime User
Upvote 0
Top