Android Question Installing B4A 11.80 (64bit)

moster67

Expert
Licensed User
Longtime User
I uninstalled the previous 32bit version of B4A and installed the new 64bit version.
The only problem I have now (so far) is that I cannot open a project from File Explorer by selecting the project file *.b4a. This would normally open B4A and the selected project.
I uninstalled B4A and then installed it again but it still won't work.

I tried by right-clicking on the project file and using "open with", I selected B4A among available programs, and of course, this works. However, if I recall correctly, in the past this would let me indicate the default program to use but on my Win10, there is no such option anymore.

Can I somewhere, perhaps in the registry, set the right association for *.b4a project files?

Thanks.
 
Solution
If you click 'more apps' does a checkbox show then? Also try this

Solved: Win 10 --> Defaulting an App of your choice to open when you click on a specific file type (and your app is not in the "Default Apps" list).

Here is a one-time process to default a specific app to open with a specific type of file, when your app of choice is not in the "Default apps" list.
Example. Let's say you want to default .txt files to open with Notepad++, but in "Default Apps" your only choices are Notepad, and WordPad.
Step 1. From "File Explorer", Right-Click on the File_Name.txt and Select "Open With".
Select "Choose another app". Then, the "How do you want to open this file?" dialog box, pops up.
Click on "More apps [down-arrow]".
After...

Erel

B4X founder
Staff member
Licensed User
Longtime User
The installer does add the required registry keys. I guess that something went wrong.

What is the output of:
assoc .b4a
ftype | findstr B4A
?

1665899769528.png
 
Upvote 0

agraham

Expert
Licensed User
Longtime User
However, if I recall correctly, in the past this would let me indicate the default program to use but on my Win10, there is no such option anymore.
2022-10-16_105156.jpg

I'm on Windows 10 and there is a checkbox above the OK button on the 'open with' dialogs.
 
Upvote 0

teddybear

Active Member
Licensed User
I tried by right-clicking on the project file and using "open with", I selected B4A among available programs, and of course, this works. However, if I recall correctly, in the past this would let me indicate the default program to use but on my Win10, there is no such option anymore.
After "open with" , don't select B4A among available programs, click "Choose another app" menu, then choose b4a, check Always use this app to open .b4a files like post#3
 
Upvote 0

moster67

Expert
Licensed User
Longtime User
What is the output of:
assoc .b4a
ftype | findstr B4A
?
The output looks similar to what you showed in your screenshot as you can see below. The only difference is that I am installing B4A in "C:\Anywhere Software\". I have always installed B4X products in the "C:\Anywhere Software\" and never had any problems.

Screenshot 2022-10-17 100609.jpg


As mentioned before, I already tried double-clicking the *.b4a file or even using "open with" and then selecting B4A. Of course, this works, but there is no checkbox to tick to say "Always use this app to open b4a files" so it is remembered for the next time:

Screenshot 2022-10-17 102559.jpg


I also tried selecting more apps, browsing the PC, and selecting the B4A program but still, there is no checkbox to make such a selection permanent.
 
Last edited:
Upvote 0

agraham

Expert
Licensed User
Longtime User
If you click 'more apps' does a checkbox show then? Also try this

Solved: Win 10 --> Defaulting an App of your choice to open when you click on a specific file type (and your app is not in the "Default Apps" list).

Here is a one-time process to default a specific app to open with a specific type of file, when your app of choice is not in the "Default apps" list.
Example. Let's say you want to default .txt files to open with Notepad++, but in "Default Apps" your only choices are Notepad, and WordPad.
Step 1. From "File Explorer", Right-Click on the File_Name.txt and Select "Open With".
Select "Choose another app". Then, the "How do you want to open this file?" dialog box, pops up.
Click on "More apps [down-arrow]".
After you clicked on Click on "More apps [down-arrow]", a bigger list of apps should be displayed.
Check the "Always use this app to open [.fileType] files" check-box, and
Scroll to the bottom and Click, "Look for another app on this PC".
Browse to your app's .exe and double-click it (or left-click and then click the Open button).
Your file will open in the app you selected, and from now on all files of that type will open with that app. In this case all text files will open with Notepad++.
 
Upvote 0
Solution

teddybear

Active Member
Licensed User
Try right-click ->properies->General->Change. Then open with, see if check-box is shown?
 
Upvote 0

moster67

Expert
Licensed User
Longtime User
Also try this
Solved: Win 10 --> Defaulting an App of your choice to open when you click on a specific file type (and your app is not in the "Default Apps" list).



Here is a one-time process to default a specific app to open with a specific type of file, when your app of choice is not in the "Default apps" list.

Example. Let's say you want to default .txt files to open with Notepad++, but in "Default Apps" your only choices are Notepad, and WordPad.

Step 1. From "File Explorer", Right-Click on the File_Name.txt and Select "Open With".

Select "Choose another app". Then, the "How do you want to open this file?" dialog box, pops up.

Click on "More apps [down-arrow]".

After you clicked on Click on "More apps [down-arrow]", a bigger list of apps should be displayed.

Check the "Always use this app to open [.fileType] files" check-box, and

Scroll to the bottom and Click, "Look for another app on this PC".

Browse to your app's .exe and double-click it (or left-click and then click the Open button).

Your file will open in the app you selected, and from now on all files of that type will open with that app. In this case all text files will open with Notepad++.
This worked. I am pretty sure I tried it before in vain but this time it did work.

Thanks, @agraham and all others helping out.
 
Upvote 0
Top