Italian Comportamento incomprensibile (per me) del Designer

ZuperMario

Member
Licensed User
Salve a tutti, ho acquistato B4A secoli fa quando era a pagamento, ma sto cercando di usarlo solo adesso.
"Provengo" dalla buonanima di Visual Basic 6.

Non capisco perche' il Designer, una volta collegato al tablet e impostato "Adatta al dispositivo connesso", mi sposta gli elementi sul display fisico del tablet in maniera corretta e coerente, mentre poi quando eseguo veramente il programma le coordinate sono tutte sballate, i controlli mi escono fuori dallo schermo.

Allego schermate

Grazie.
 

Attachments

  • 2023-04-11 13.40.25.jpg
    2023-04-11 13.40.25.jpg
    439.5 KB · Views: 62
  • 2023-04-11 13.41.33.jpg
    2023-04-11 13.41.33.jpg
    393.1 KB · Views: 59
  • Cattura1.PNG
    Cattura1.PNG
    79.6 KB · Views: 60

Star-Dust

Expert
Licensed User
Longtime User
Hai ancorato solo a sinistra e quindi hai un risultato diverso in base alla larghezza del device.
Devi ancorare entrambi i lati.


PS. Adesso è gratis aggiorna all'ultima versione
 

Sagenut

Expert
Licensed User
Longtime User
O.T. Strano....dovresti essere già "licenziato!" :)
Forse non si è registrato al forum con la stessa email.
Comunque se contatta il supporto e dimostra l'acquisto dovrebbe ottenere subito il "Licenziamento". 🤣
 

ZuperMario

Member
Licensed User
Forse non si è registrato al forum con la stessa email.
Comunque se contatta il supporto e dimostra l'acquisto dovrebbe ottenere subito il "Licenziamento". 🤣
Vero, l'avevo acquistato con un'altra email, che poi ho chiesto di modificare in un'altra, che ora uso in sola lettura e la registrazione al forum l'ho fatta con GMAIL non ricordando di avere (probabilmente) già l'account con l'email vecchia ma funzionante 🤦‍♂️
 

Smb

New Member
Forse non si è registrato al forum con la stessa email.
Comunque se contatta il supporto e dimostra l'acquisto dovrebbe ottenere subito il "Licenziamento". 🤣
Non mi riconosce nemmeno con questo account che era collegato all'acquisto 🤔 Quale supporto devo contattare, qui sul forum o dall'interno del programma?
 

Sagenut

Expert
Licensed User
Longtime User
  • Like
Reactions: Smb

ivanomonti

Expert
Licensed User
Longtime User
nelle foto non vedo ancoraggi ma poi il form è enorme a mio dire, usa una variante più piccola e aggiungi gli elementi ben ancorati è il probrlema lo risolvi
 
Top