Android Question Error compiling : --min-sdk-version >= 25

Pedro Caldeira

Active Member
Licensed User
I am having this error even after update the sdk, Any ideias:

B4X:
B4A Version: 9.50
Java Version: 8
Parsing code.    (0.04s)
Building folders structure.    (0.09s)
Compiling code.    (0.07s)
Compiling layouts code.    (0.01s)
Organizing libraries.    (0.00s)
    (AndroidX SDK)
Generating R file.    (0.34s)
Compiling debugger engine code.    (2.90s)
Compiling generated Java code.    (2.31s)
Convert byte code - optimized dex.    Error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
7 errors; aborting
 

Computersmith64

Well-Known Member
Licensed User
Maybe set minSdkVersion="26" in your manifest? Or possibly you need to be building using android.jar from SDK 26+ (set in the paths configuration in B4A)?

Also - when starting a new thread, you might want to include something about your issue in the title instead of just "Hello all". :)

- Colin.
 
Upvote 0

DonManfred

Expert
Licensed User
Upvote 0

Similar Threads

Top