Android Question error "current module does not support adding members"

Discussion in 'Android Questions' started by rleiman, Feb 25, 2018.

  1. rleiman

    rleiman Well-Known Member Licensed User

    Hi Everyone,

    After adding a custom view I get the following errors when trying to add a member using the "Generate" menu item.

    Why? I thought we are allowed to add them to custom views.

    Do I need to set something? This is happening to all custom views I try to add a member to.

    The attached screen shots shows what happens when I tried to add the Dim statement.

    Thanks.
     

    Attached Files:

  2. rleiman

    rleiman Well-Known Member Licensed User

    Looks like I may have found a bug in the designer.

    I added an image view and tried to add some members to it and was able to do so. Next I tried to do the same thing to the custom views and I was able to do it without any errors.

    The error originally happened after I copied and pasted a custom view from another app so it seems the coping and pasting caused the error to surface.
     
  3. Erel

    Erel Administrator Staff Member Licensed User

    You probably did it while a static code module or service where selected in the main editor.
     
  4. rleiman

    rleiman Well-Known Member Licensed User

    Hi Erel,

    An activity module was open at the time but the next time it happens, I will try closing the designer and clicking through the other modules and returning to the activity module or closing the app and re-opening it and try again.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice