iOS Question Local Mac Builder - After compiling successfull nothing happen on B4i-Bridge

Mike1970

Well-Known Member
Licensed User
Hi, i'm manged finally to compile on a local mac, but when the compiling finish nothing happends, it's normal?
Or i've to do something?

In these days, i tried to restart several times, and NOW after i published this post (karma was waiting for this), it worked for the first time.
It seems to be unstable however.
 

Erel

Administrator
Staff member
Licensed User
Make sure that:
1. Run Installed Apps Automatically is checked in the build server settings.
2. There is only one debug app installed on the device.

After a successful (full) compilation, the IDE sends a command to B4i-Bridge which starts installation. You should see a prompt that asks you to allow the installation. It can take a while until you see this dialog.
 
Upvote 0

Mike1970

Well-Known Member
Licensed User
Make sure that:
1. Run Installed Apps Automatically is checked in the build server settings.
2. There is only one debug app installed on the device.

After a successful (full) compilation, the IDE sends a command to B4i-Bridge which starts installation. You should see a prompt that asks you to allow the installation. It can take a while until you see this dialog.

Yes on one phone now it works. On the other it shows “can’t connected to <ip>” maybe it’s old the bridge on that one?
 
Upvote 0

Mike1970

Well-Known Member
Licensed User
Make sure that:
1. Run Installed Apps Automatically is checked in the build server settings.
2. There is only one debug app installed on the device.

After a successful (full) compilation, the IDE sends a command to B4i-Bridge which starts installation. You should see a prompt that asks you to allow the installation. It can take a while until you see this dialog.

iPhone 6
IMG_9612.PNG


I also tried to uninstall the bridge and reinstall (in fact the screenshot represent that moment 😂)
On my iPhone XR no problems. So I don't think is the router config
 
Last edited:
Upvote 0

JordiCP

Well-Known Member
Licensed User
Possibly the problem is that you must install (download + activate) the B4I certificate in your device

Download:
Open Safari (device browser) and navigate to: www.b4x.com/ca.pem

Install (or double-check that it is active, if you had already done this previously)
iOS 10+: Go to Settings - General - About - Certificate Trust Settings and enable the B4I certificate. The certificate is required for the over the air installation.
 
Upvote 0

Mike1970

Well-Known Member
Licensed User
Possibly the problem is that you must install (download + activate) the B4I certificate in your device

Download:


Install (or double-check that it is active, if you had already done this previously)

Ok i will try, unfortunatly the phone is not mine, so now i had to wait to test again :/
 
Upvote 0
Top