Other minSDK version

sorex

Expert
Licensed User
Hello,

I uploaded a new apk file the the Play store and now it suddely gives this message...

You uploaded an APK that uses Google Play services version 4030500. This will only work with Android API levels of 9 and above. It is discouraged to use this Google Play services version unless you have set the minSdkVersion in your manifest to 9 or higher
yesterday it didn't give that.

I see in the manifest editor that I can edit that line.

1. Should I do that
2. What impact could it have to my app?
3. What's the minimum OS that my app will require?
 

MarcoRome

Expert
Licensed User
Android 1.0 - (API level 1)
Android 1.1 - (API level 2)
Android 1.5 Cupcake (API level 3)
Android 1.6 Donut (API level 4)
Android 2.0 Éclair (API level 5)
Android 2.0.1 Éclair (API level 6)
Android 2.1 Éclair (API level 7)
Android 2.22.2.3 Froyo (API level 8)
Android 2.3–2.3.2 Gingerbread (API level 9)
Android 2.3.3–2.3.7 Gingerbread (API level 10)
Android 3.0 Honeycomb (API level 11)
Android 3.1 Honeycomb (API level 12)
Android 3.2–3.2.6 Honeycomb (API level 13)
Android 4.0–4.0.2 Ice Cream Sandwich (API level 14)
Android 4.0.3–4.0.4 Ice Cream Sandwich (API level 15)
Android 4.1–4.1.2 Jelly Bean (API level 16)
Android 4.2–4.2.2 Jelly Bean (API level 17)
Android 4.3–4.3.1 Jelly Bean (API level 18)
Android 4.4–4.4.4 KitKat (API level 19)
Android 4.4W–4.4W.2 KitKat, with wearable extensions (API level 20)
Android 5.0–5.0.2 Lollipop (API level 21)
Android 5.1–5.1.1 Lollipop (API level 22)
 
Top