Bug? Problem in Design

Discussion in 'iOS Bugs & Wishlist' started by Star-Dust, May 16, 2019.

  1. Star-Dust

    Star-Dust Expert Licensed User

    By creating an XUI view, today I realized that the view properties do not appear.
    On B4J and B4A instead they appear correctly.

    In doubt I have opened other XUI iews that I created in the past and that the properties appeared correctly, now in no view do the properties appear.

    So I thought it was a b4i problem and reinstalled but with no results.
    For proof, I created empty projects, with a new XUI view (empty) and the properties do not appear to me

    Code:
    #DesignerProperty: Key: TextColor, DisplayName: Text Color, FieldType: Color, DefaultValue: 0xFF000000, Description: Text color
    #DesignerProperty: Key: BackColor, DisplayName: Background Color, FieldType: Color, DefaultValue: 0xFFF0F0F0, Description: BackGround color
    upload_2019-5-16_19-43-11.png
     

    Attached Files:

  2. Erel

    Erel Administrator Staff Member Licensed User

    I can only guess that you haven't reselected the view after you added the properties. Click on the main page and then back on the custom view and it will work.
     
  3. Star-Dust

    Star-Dust Expert Licensed User

    As you can see in the image it is selected and I have also tried empty projects.
     
  4. Star-Dust

    Star-Dust Expert Licensed User

    I must say that this afternoon it worked properly.
     
  5. Erel

    Erel Administrator Staff Member Licensed User

    You need to click on the main control and then back on the custom view. If it doesn't work then please upload the project.
     
  6. Star-Dust

    Star-Dust Expert Licensed User

    I have done many other tests.

    Finally I managed to get the properties, but if I insert the _ character (as an example SD_text) it blocks me the design and all the views that I create later are not recognized the properties.

    So I have to close B4i, restart it and open a named view that doesn't contain underscores
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    Please upload a small project that demonstrates it.
     
  8. Star-Dust

    Star-Dust Expert Licensed User

    satisfied
     

    Attached Files:

  9. Star-Dust

    Star-Dust Expert Licensed User

    however I solved by changing the name to the custom view
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    This is indeed a bug related to the underscore. It is fixed for the next update.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice