Android Question Running B4A via VirtualBox on Linux

nypaulie

Active Member
Licensed User
I've been having problems with B4A running on Window 7 using VirtualBox on my Linux (Mint) OS, so I decided to start from scratch and installed Windows PRO XP (also on VBox). I get everything completed successfully, but when I configure my paths I continue to get this error when I get to the android.jar:
An error occurred.
The specified executable is not a valid
application for this OS platform.
I've downloaded, unpacked and installed many different packages including, of course, the recommended one. I even reinstalled the .net framework (desperation taking effect).
I have no problems running B4A on my dual-booted Windows-10 but VBox use saves me time. I am not a Windows fan as you can tell.

[Added 3/30/2019]
Just to follow up on this thread that I'd started... I decided to throw in the towel trying to use Win-XP and installed a clean new copy of Win-7 on VBox with my Linux (Mint-Rosa 17.3) host. Installed B4A, the JDK and SDK (this time using the "ready-to-run" link). I am once again compiling/running with ease. Thanks to all for your help!
 
Last edited:

nypaulie

Active Member
Licensed User
You can download the "Ready to run" sdk. It might work. The problem is not in B4A but rather in Android SDK.
I downloaded the ready-to-run sdk, but configuring the path to the "new" android.jar gave me the same error that I had shown a few posts above. BTW, I am using the 8.80 registered version of B4A.
 

nypaulie

Active Member
Licensed User
Ignore this message. What happens when you try to compile the project?
It won't compile - I get another error saying Please configure paths. Here's a shot.
User jahswani suggested WinXP might not be an acceptable OS to use. Think that's it?
I am trying to install a fresh Win-7, but downloading a copy is iffy today for me.
 

Attachments

Martin Larsen

Active Member
Licensed User
I use latest B4A on XP in VirtualBox on Linux without problems of any kind. I use GenyMotion as emulator directly on Linux, and B4A debugger talks to that also without problems.
 

nypaulie

Active Member
Licensed User
I use latest B4A on XP in VirtualBox on Linux without problems of any kind. I use GenyMotion as emulator directly on Linux, and B4A debugger talks to that also without problems.
My problem apparently is with SDK. I've tried many different installations and keep getting the same error msg when I try to configure the path to "android.jar". Can you please tell me which installation you are using and maybe attach a link? Here's a shot of what keeps happening.
 

Attachments

nypaulie

Active Member
Licensed User
I use latest B4A on XP in VirtualBox on Linux without problems of any kind. I use GenyMotion as emulator directly on Linux, and B4A debugger talks to that also without problems.
I wanted to take a look at GenyMotion so I installed it. When I try to open it for the 1st time I get an error saying I need to have VirtualBox installed. I Do have it installed. Guess I just can't win. I sent a note to Geny-support with a screenshot of my VirtualBox running and the error msg. BTW, I am running Linux 17.3 Rosa.
 
Top