iOS Question Second App!

Discussion in 'iOS Questions' started by Andrew A Gray, Aug 2, 2018.

  1. Andrew A Gray

    Andrew A Gray Member Licensed User

    OK, I now am published with my first app on BOTH the App Store and Play Store! Wow.
    Anyway, I need to develop a SECOND iOS app. I did create a wildcard ios app id ( .* ), as you suggested.
    Now you have some parameters in the .b4i file that are not shown in the IDE. Notice the
    first line in my .b4i file (that I must use another editor to see):

    Code:
    Build1=Default,AvtecCam.app
    File1=
    1.bil
    File10=off.png
    File11=on.png
    File2=
    2.bil
    File20=workshop.png
    .
    .
    .
    @EndOfDesignText@
    My app id is AvtecCam.*. Where do you set the "AvtecCam.app" name?
    It is also in the B4iProject-Info.plist file ...
    You said you can do multiple apps with the wildcard app id ".*" ...
    So do I need a new mobileprovision and csr for the 2nd app?

    Andrew
     
    Last edited: Aug 2, 2018
  2. Alexander Stolte

    Alexander Stolte Well-Known Member Licensed User

    in the IDE click "Project" --> "Build Configurations" and then "Package"
     
  3. Andrew A Gray

    Andrew A Gray Member Licensed User

    Ok. Thanks. I'll give a go!
     
  4. Andrew A Gray

    Andrew A Gray Member Licensed User

    Wow. This is weird. Everything was working....

    I just wanted to change to my 2nd app.

    So, as instructed, I changed my

    Project->BuildConfigurations->Package

    from AvtecCam.app ... to ... AvtecCam.view.....

    and deleted AvtecCam from my iPhone.
    Then I ran Debug and it installed and worked. Great. Then I tried "Build Release App",

    AND THIS NO LONGER WORKS! B4i-Bridge just sits there and does nothing.

    So I thought to rebuild the B4i-Bridge and re-install. I did this... Still, B4i-Bridge just sits there in "Release Mode", and does not respond (and does not show designer).
    I rebooted my iPhone and my PC. Deleted AvtecCam again. No help.
    It does install debug mode sometimes, but not "Release Mode". Then I deleted B4i-Bridge, went to re-install it with builder1 at port 51041 and weirdly,

    Builder1.b4x.com INSTALLED MY "AvtecCam.view" app, not the B4i Bridge.

    What is going on???
    (At least I am not out of business today, as I can compile and bypass B4i Bridge)
     
    Last edited: Aug 7, 2018
  5. Andrew A Gray

    Andrew A Gray Member Licensed User

    Update:
    I went and got my iPad (2018) and the B4i-Bridge worked on that in "Release Mode".
    It asked to install AvtecCam, and it did.

    So something happened to my iPhone 6 plus that makes the B4i-Bridge not work on it.
    On my iPhone 6 plus, the debug-mode is not even working anymore.
    (But I can still install AvtecCam directly from builder1).

    Any ideas, anyone?

    Andrew
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    If it installs in release mode and fails to install in debug mode then the CPU architecture is probably misconfigured. Tools - Build Server - Settings.
     
  7. Andrew A Gray

    Andrew A Gray Member Licensed User

    Ok, I'll give that a try. Thanks!!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice