Android Question [SOLVED] SDK update causes ERROR : The system cannot find...

Discussion in 'Android Questions' started by rabbitBUSH, Jun 7, 2019.

  1. rabbitBUSH

    rabbitBUSH Member Licensed User

    ERROR The system cannot find the file specified

    COMPILE AND RAPID DEBUG MESSAGE BOX text

    B4A Version: 9.01.2
    Java Version: 8
    Parsing code. (0.20s)
    Building folders structure. (0.30s)
    Compiling code. (0.48s)
    Compiling layouts code. (0.03s)
    Organizing libraries. (0.00s)
    Generating R file. (0.00s)
    Compiling debugger engine code. (0.04s)
    Compiling generated Java code. (0.41s)
    Convert byte code - optimized dex. (8.39s)
    Packaging files. (3.81s)
    Copying libraries resources (0.00s)
    Signing package file (debug key). (5.12s)
    ZipAlign file. (0.69s)
    ----> Installing file to device. Error
    ----> The system cannot find the file specified


    Updated my B4A package SDK through SDK Manager (3.34) : did the recommended ones and added the android platform 29 stuff for fair measure.

    This was with B4A 9.00 loaded and just did the update to 9.01.2 about an hour ago to see if that addressed the reported error and issue - Nope.

    [It looks like this error is a so-called false positive, since: "...the file specified..." appears to refer to a failure to connect to the phone device and not to finding a "file" as such.]

    Normally : (and this has been working fine since I licensed B4A a few months ago) the phone used for developing is linked via USB Debug Mode. Phone is changed to developer. It also has B4A Bridge installed but this is not used because B4A log does not appear in the IDE unless the link is USB {but see below}.

    After the above updates the USB link has disappeared. And, using the B4A Bridge the same error occurs. So, both debug methods are not functioning now.

    For a short while after the update, the USB link continued to talk to the phone, but, the whole file was not installed to the device - just the basic APP "box" and the APP title bar showed; then, the install failed in the middle, same error reported. After closing down and coming back next day the above shown error is all that appears.

    Hunted the PC for a log file that might tell me something but couldn't find anything.

    Have hunted the Forum and found some references to the above error, but, none of the solutions gave any results here.

    Incidentally, I have tried on two phones (both Mr Trump's favourite: Huawei, one is ALE-L02 the other P20-lite) and neither connects through with either debug method.

    I suspect that something has gone wrong with the authorisation between the phone and the PC so that the phone allows debug through the PC to happen. ​

    So, have spent a few hours checking this and that and the next thing, now run out of ideas and I'm stuck in the middle of a project with no debug mode option.

    Any clear suggestions would be welcomed.

    thank you forum members......in advance.....
     
  2. Scantech

    Scantech Well-Known Member Licensed User

  3. rabbitBUSH

    rabbitBUSH Member Licensed User

    thanks Scantech for a quick comeback : missed those, guess it depends on the search criteria... anyway am trying to get the adb.exe changed / overwritten / updated as suggested in the threads you've pointed out - seems like now I am in a battle with Windows 10 about who IS the administrator and HAS permission to write to the folder....What I did find is that adb.exe seems to have disappeared from the platform-tools folder - - - - gofigure - - - tried the restart adb server button in B4A but got an error about not finding the path and a request to configure paths which showed that the file actually wasn't there anymore.

    won't really know until I get that copy thing sorted out...... :mad:
     
  4. rabbitBUSH

    rabbitBUSH Member Licensed User

    hello again SCANTECH -> just to let you know that I have finally beaten W10 back (too late at night to have an explanation of how) but anyway after a reboot or two and so on and so forth I managed to replace the adb.exe file in its proper place and things are back working again; and, learnt a thing or two along the way.

    My guess is that something in the SDK update process deleted the file for whatever reason - (who knows Most of the time?).

    As I said my search criteria just didn't find those threads.

    So - once again thanks for the assist - with greetings from Africa - cheers.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice