Android Question strange behavior of my code ? or of IDE?

Discussion in 'Android Questions' started by Bergin, Oct 12, 2019.

  1. Bergin

    Bergin Member Licensed User

    Hi All,

    I did a large program which started to have a strange behavior. I removed nearly all codes and it continues to have this strange behavior :
    1. I "compile & execute" with F5 and IDE failed to install the Apps on my phone.
    2. I re "compile and execute" and the Apps works well
    3. I uninstall the Apps from my phone
    4. I re re "compile & execute" with F5 and it failed again like in 1.

    Did someone already face the same situation ?
    thank for help
     

    Attached Files:

    Last edited: Oct 13, 2019
  2. JohnC

    JohnC Well-Known Member Licensed User

    What is the exact error message displayed when your app doesn't install onto your phone?

    Does it happen when using a different device or the emulator?
     
  3. Bergin

    Bergin Member Licensed User

    I think you saved my day. in the error message it was said that sometimes the project has to be cleaned. So I cleaned it and it worked!
    I wonder why F5 doen not clean the project at the same time ?
    (I am using a device)
    Thanks a lot
     
    JohnC likes this.
  4. Erel

    Erel Administrator Staff Member Licensed User

    1. The compiler tries to reuse all kinds of things between compilations to make the compilation and deployment faster. This is why it doesn't "clean" the project automatically.
    2. The compiler doesn't know that you have uninstalled the app from the device. So you need to clean the project (Ctrl + P) to force it to build everything.
     
  5. Bergin

    Bergin Member Licensed User

    I understand.
    thanks a lot .
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice