Android Question AR Library Compilation ERRORS (requires --min-sdk-version >= 26)

Discussion in 'Android Questions' started by walterf25, Aug 25, 2019.

  1. walterf25

    walterf25 Well-Known Member Licensed User

    Hi All, i'm trying to play around wrapping some parts of Google's ARCore Library, however i keep getting the following error, i've seen this before but i'm not sure how I was able to get rid of this error, does anyone have ant suggestions, I have been going at this for almost an entire day without any success, i have copied both the Jar and .aar files to the additional libraries folder so i'm really not sure at this point what the issue could be.

    The error is the following:
    I will really appreciate if someone could shed some light on this problem, i really would like to wrap the ArSceneView View at and the ArSceneFragment part of this library.

    Thanks in advance, hope i can get some answers soon.

    Walter
     
  2. JohnC

    JohnC Well-Known Member Licensed User

    In the manifest file:
    Code:
    <uses-sdk android:minSdkVersion="21" android:targetSdkVersion="26"/>
    Try changing the first part (minSDKversion) to "26" (as described in the error message).

    Then see what happens...
     
    Last edited: Aug 25, 2019
  3. JohnC

    JohnC Well-Known Member Licensed User

    DonManfred and Erel like this.
  4. Erel

    Erel Administrator Staff Member Licensed User

  5. DonManfred

    DonManfred Expert Licensed User

    the solution posted will probably not help at all as AR Apps needs to be a InstantApp. I mean if google does not changed this requirement in the meantime...
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice