Android Question B4A Designer WSIWYG is not connecting to my device

Lori Scott

Licensed User
My B4A-Bridge status says Connected. But in the Designer, my WYSIWYG status says Disconnected. When I click it to connect, I get this:
View attachment 69032
When I try to restart ADB Server from the Tools menu, I get this:
View attachment 69033
When I search my PC for the file adb.exe, nothing is found.
When I open the Configure Path window, I have been trying to configure this correctly. So far I have this:
View attachment 69034
I have two \jdk1.8.x_xxx folders, jdk1.8.0_171 and jdk1.8.0_172. I've tried both. I suspect they're not the problem.
I couldn't find an android.jar file on my computer so, I Googled it and ended up downloading Android Studio to get it.
Also tried opening the SDK Manager. To get a sdkmanager.bat file, I downloaded sdk-tools-windows-4333796. It was in my Download folder and I moved to to my Program Files. Now I have this:
View attachment 69035

From here, I tried the Install Selected button (everything was already checked as recommended for Install). It proceeded until 91% and stopped with an error message about being unable to do something with a configuration file (I failed to capture the error when I cancelled out of the process).

Now that I have the sdk-tools-windows-4333796, I see that it has both an android.jar file and an abd.exe file. I changed my configurations to point to the android.jar file from sdk-tools-window-4333796 instead of from AndroidStudio.
View attachment 69037
Still when I try to Restart ADB Server from the Tools menu, I get this:
View attachment 69038

It appears to be looking for the adb.exe file under c:\Program Files\tools\...
There is no \tools folder on my PC under \Program Files.
The adb.exe is actually located at C:\Program Files\sdk-tools-windows-4333796\platform-tools so it is looking down the wrong path. I made a C:\Program Files\Tools\ folder and copied the \platform-tools folder (with adb.exe) into it. I get the same error.

The first time I opened B4A-Bridge, I did see a WYSIWYG view pop up on my Android device, however it was blank. When I added elements within the Designer, they did not show up on the device as shown in the tutorial. I'm not sure what I did on the device, but even that blank WYSIWYG no longer show up. I cannot get WYSIWIG to connect from the desktop.

My device is a Samsung SM-J320V with Android Version 7.1.1.

I don't know what to try next. Can you please guide my efforts?

Lori Scott

Licensed User
Thank you. I was able to connect the WYSIWYG by following the similar thread (GUI SDK Manager for newer versions of Android tools) and storing the android.jar file here:
Upvote 0