Android Question problem with adb


New Member
hello to all, im new in this world of b4a.
im starting to program using b4a on win xp. i installed all required (jdk, sdk, b4a) and everything seems to work.
But when i try to compile my app and put it on my android device connected through b4a bridge i recive the error "adb.exe impossible find entry point" - Impossible to find the entry point WSAPoll of procedure in dynamic library ES2_32.dll.
Also restarting the adb server i recive the same error.
Is there any suggest to fix it ?
thank you


Licensed User
Longtime User
Hi Rick, I am also running XP on my PC and have been struggling for more than a week with exactly the same problem "The procedure entry point WSAPoll could not be located in WS2_32.dll.
Thanks to your suggestion above, I have also loaded Platform-Tools 16.0.1 and the problem is solved!
How did you ever figure out that an earlier version of Platform-Tools was needed?
Well done and thanks VERY MUCH. Regards Gerrard
Upvote 0


Licensed User
Longtime User
Upvote 0

Martin Larsen

Active Member
Licensed User
Longtime User
It also worked for me. There was already a folder named platform-tools so I just renamed that and copied the one from the zip filer over.

Upvote 0