iOS Question sudden problem compiling code

Discussion in 'iOS Questions' started by abarnett, Jul 20, 2019.

  1. abarnett

    abarnett Member Licensed User

    Not sure what has happened, but I went to recompile and old program (3 months old) and now getting this problem.

    error: Provisioning profile "iBloxDev" doesn't include signing certificate "iPhone Developer: xxxxx (yyyyyyy)". (in target 'B4iProject').

    I have renewed hosted subscription and profiles in case they were expired.

    Any clues where to look
     
  2. emexes

    emexes Well-Known Member Licensed User

    I am no expert, I just know that when switching between development compiles and App Store compiles, I have to change both Project, Build Configuration and Tools, Configure Paths, Keys Folder ('cause I was so confused in the early days about which key file was being used, that I put each key file in its own folder). So I thought maybe you'd used the wrong combination, but I tried to reproduce your error, and couldn't.

    So all I can offer is this Google search for "provisioning profile" and "include signing certificate" and perhaps this post from someone with the same error message.
     
  3. emexes

    emexes Well-Known Member Licensed User

  4. Erel

    Erel Administrator Staff Member Licensed User

    No need to use Google. There is a very good and customized search engine in this forum.

    This error means that the provision profile and the certificate file do not match. The simplest way to solve it is to delete both and download the correct ones again.
     
  5. emexes

    emexes Well-Known Member Licensed User

    Agreed, and it is always my first port of call and I am often pleasantly surprised. But it does not seem to search for specific phrases, which is what was needed here to easily find references to the error message amongst all the more general posts about App Store provisioning and signing.

    Google is my second port of call, mostly for searching on phrases, and less often for exclusions eg -"android studio" (can't think of a good example out of the blue, and my memory's not what it used to be). Perhaps there is some way to do those in the B4X forum search and I just haven't discovered it.

    https://www.b4x.com/android/forum/threads/advanced-forum-search.57219/#post-365400
     
  6. emexes

    emexes Well-Known Member Licensed User

    Erel likes this.
  7. abarnett

    abarnett Member Licensed User

    Thanks Erel and everyone else. Found the problem. The dev profile when i regenerated it was AdHoc and not a development profile so removed it a recreated. Now All ok.
     
    Last edited: Jul 21, 2019
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice