Bug? V5 Designer not usable

Discussion in 'Bugs & wishlist' started by goldmagnet, Jun 9, 2015.

  1. goldmagnet

    goldmagnet Member Licensed User

    The designer in V5 is too buggy to be usable.

    I have recompiled my projects in V5 and the memory leaks are all gone. But now in a new project created in V5 I cant use the designer. Try this:

    Create a new layout.
    Add 3 panels that cross the entire layout, i.e. each one is a third of the screen.
    Add a big panel underneath.
    Now rename the firstpanel to TPanel1.
    Now try and select the middle panel.

    I get lots of very weird behavior then errors like the item is missing from the directory. I can not create the layouts I want, it falls over in lots of ways.
     
  2. goldmagnet

    goldmagnet Member Licensed User

    "The key was not present in the directory".

    Also moving one object causes others to fly off the screen.
     
  3. klaus

    klaus Expert Licensed User

    Add a big panel underneath.
    Underneath what?
    What is its paent View ?

    I tried what you explain but I'm not sure if it's exactl what you did.
    I added three Panels each one third in the height.
    Selected Activity, and added a forth Panel filling the whole screen and sent it to back.
    Renamed Panel4 to TPanel1 and it works as expected !

    Did you send TPanel1 to back ?
    If no, you can't select a Panle underneath.
     
  4. goldmagnet

    goldmagnet Member Licensed User

    The errors do not seem to occur if you leave control names at default.
     
  5. goldmagnet

    goldmagnet Member Licensed User

    I am just uploading a video to show you the issue, 15 minutes....
     
  6. goldmagnet

    goldmagnet Member Licensed User

    Here you are its an unlisted vid:
     
  7. goldmagnet

    goldmagnet Member Licensed User

    I have tried to create this layout 10 times now, including a reboot and starting from scratch, no joy I always get the error at some point. I will have to use the V4 designer on another PC until a fix is available. It seems repeatable, just add a bunch of controls and rename a few and you get errors, shame as generally I prefer the V5 editor.
     
  8. goldmagnet

    goldmagnet Member Licensed User

    If it helps debugging, you do not see these errors if you save the layout after you add each control.
     
  9. gruizelgruis

    gruizelgruis Member Licensed User

    I have the same problem. Lets say I add 2 labels to the desighner.
    When I change the name of the first label. and klick on the second, The error occurs.
    But when I change the name of the 1st label and klick on the eventname of that same label.
    the event name changes accordingly, and the error is not there.

    It's looks like the whole renaming sequence does not finish when the focus leaves that object.

    Hope it helps
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    I see it too. As @gruizelgruis wrote it happens when you change the name and select a different control. It is fixed for the next update.

    For now make sure to press on Enter after you change the name. It will commit the change.
     
  11. goldmagnet

    goldmagnet Member Licensed User

    Thanks Erel, once the next build is out it will be great.
     
Loading...