Italian Versione Release errore!!

GIS

Active Member
Licensed User
se lancio l'applicazione con il debug non mi dà nessun tipo di errore e funziona tutto correttamente. quando invece lancio l'applicazione in modalità release si apre correttamente quando vado a fare l'accesso e cioè l'evento accedibotton_click vado a scaricare un file col download e ho il whait for. a questo punto nei log mi da questo errore è l'applicazione si chiude in modo anomalo. comunque a pensarci bene credo che si blocchi quando ho finito il wait for Lancia una nuova Activity, anche se non riesco a capire il momento esatto chi dà errore comunque penso che sia in questo frangente . ripeto La cosa strana è che col debug l'applicazione funzione in modo corretto l'ho provata anche su altri dispositivi e il problema è identico
 

LucaMs

Expert
Licensed User
Senza vedere il codice penso sia impossibile darti una mano.

Si vede solo che usi una resumable (dovuta al Wait For) e una msgbox; che succede se al posto della msgbox metti un toast o un log?
 
  • Like
Reactions: GIS

GIS

Active Member
Licensed User
ok pensavo che nn era necessario visto che col debug funziona. Stasera se riesco metto il codice altrimenti Lunedi
 

GIS

Active Member
Licensed User
Buonasera, ho studiato meglio il listato e ho capito dove era il problema anche se nn me lo so spiegare, anche perché sono ancora alle prime armi con B4A. Praticamente in un ciclo for non mi lanciava starActivity. Cmq ho risolto. Ho una domanda. Come si forza l'uscita da un ciclo for? Era mia coseitudine forzare l'uscita aumentando la variabile del ciclo for. es. for i=0 to 10 io mettevo i=11 ma qui nn potevo perché mi serve il valore i. Sono ancora all'antica come programmazione....Grazie
 

LucaMs

Expert
Licensed User
Non mi pare proprio il caso di mettere uno StartActivity all'interno di un ciclo.

Per uscirne, Exit.
 
Top