Other B4A 9.01.2 Installing file to device. Error [Resolved see post 34]

Status
Not open for further replies.

itgirl

Active Member
Licensed User
After updating to V 9.01.2 I get a weird error [Installing file to device. Error] even though the app is installed on the device but the problem is with the Debug mode it gives the same message but the debug process does not work ??!! any one encountered this issue too ?

I disabled my Antivirus also tried to run B4A as administrator none worked ??

B4A Version: 9.01.2
Java Version: 11
 

JohnC

Well-Known Member
Licensed User
Try:

1) Uninstalling the existing copy of the app on the device
2) Reboot you device
3) Then try again.
 

itgirl

Active Member
Licensed User
Already did that along i tried to restart the phone also changed the phone all the same :/
 

JohnC

Well-Known Member
Licensed User
is your device connected via USB or B4A-Bridge and if B4A-Bridge, does it say "connected" on your device?
 

itgirl

Active Member
Licensed User
is your device connected via USB or B4A-Bridge and if B4A-Bridge, does it say "connected" on your device?
It's connected through USB , and ADB working no problems, the strange thing is when i compile using release it give the same error but the app installed on the device with no problem , the same goes for debug but when using debug the app crash
 

JohnC

Well-Known Member
Licensed User
It seems like a problem with the device talking back to B4A....firewall issue?

I know this seems silly, but maybe try rebooting your PC?
 

itgirl

Active Member
Licensed User
It seems like a problem with the device talking back to B4A....firewall issue?

I know this seems silly, but maybe try rebooting your PC?
Actually it does not seems silly at all in fact i did restart my laptop also the firewall is off along with my antivirus tried to search for any updates for windows along side with the android sdk updates nothing worked .
 

JohnC

Well-Known Member
Licensed User
Well, that was the easy stuff to try....very strange that it started with the new B4A version.
 

jimmyF

Active Member
Licensed User
Try this: Do NOT install as Administrator. Install as User
 

jimmyF

Active Member
Licensed User
i was using as a user then when it did not work i tried as administrator
But did you INSTALL as an Administrator or as a User?
 

Computersmith64

Well-Known Member
Licensed User
Has anything changed in the manifest when compiling with the new version? If you were able to install/run the same app on the same device prior to updating B4A, then you need to look at possible changes in the compiled app with the new version.

Alternatively, did you also install Java 11 at the same time you updated B4A? Did you run SDK manager? Is it possible the version of ADB you have installed isn't compatible with Java 11?

- Colin.
 

Dey

Active Member
Licensed User
After updating to V 9.01.2 I get a weird error [Installing file to device. Error] even though the app is installed on the device but the problem is with the Debug mode it gives the same message but the debug process does not work ??!! any one encountered this issue too ?

I disabled my Antivirus also tried to run B4A as administrator none worked ??

B4A Version: 9.01.2
Java Version: 8

Hello
Same problem!
have you managed to solve?
 

Dey

Active Member
Licensed User
Hello
Same problem!
have you managed to solve?
made a new app
tried to compile and send to device
same mistake.
Today I updated B4A from version 9.01 to 9.01.2
if I remember correctly I also updated SDK manager
B4A Version: 9.01.2
Java Version: 8
Parsing code. (0.00s)
Building folders structure. (0.02s)
Compiling code. (0.00s)
Compiling layouts code. (0.00s)
Organizing libraries. (0.00s)
Generating R file. (0.00s)
Compiling debugger engine code. (0.00s)
Compiling generated Java code. (0.00s)
Convert byte code - optimized dex. (0.36s)
Packaging files. (0.24s)
Copying libraries resources (0.00s)
Signing package file (debug key). (0.72s)
ZipAlign file. (0.05s)
Installing file to device. Error
 

itgirl

Active Member
Licensed User
Has anything changed in the manifest when compiling with the new version? If you were able to install/run the same app on the same device prior to updating B4A, then you need to look at possible changes in the compiled app with the new version.

Alternatively, did you also install Java 11 at the same time you updated B4A? Did you run SDK manager? Is it possible the version of ADB you have installed isn't compatible with Java 11?

- Colin.
In fact i was using older java with the same problem and i thought it was the java issue so i updated to java 11 and made sure all SDK are up to date and the problem still , nothing is changed in the app also i tried with 5 more other apps which i did not change either
 
Status
Not open for further replies.
Top