Other B4J - New IDE is available (BETA)!!!

Discussion in 'B4J Questions' started by Erel, Apr 30, 2015.

  1. Daestrum

    Daestrum Well-Known Member Licensed User

    If I use the Edit > find/replace from menu bar or F3 shortcut, I get this
     

    Attached Files:

    le_toubib and Peter Simpson like this.
  2. Peter Simpson

    Peter Simpson Expert Licensed User

    Hello @Erel,
    No errors to report, no crashing, no slowdown, no IDE (flashing, colour) issues or any other bugs to report from me (apart from the previous post). This is boring, there's nothing new to report, it's near perfect :rolleyes:

    May I suggest that you have an icon at the top of the screen maybe '?', or '!', that when clicked brings up a quick reference popup box showing all the short cut keys, as there are a lot to learn now.

    For example:
    - Press on Ctrl + Click to jump to an identifier (sub, variables, etc.).
    - Themes - Ctrl + T
    - Find all references - F7.
    - Quick search - Ctrl + F.
    - Goto sub / module - Ctrl + E.
    including Ctrl + Space
    F5
    Alt-F5
    Alt-F3
    Ctrl+P
    Etc, etc, etc, etc, the list goes on. I know that they are already available in the drop down menu, but a quick reference popup would not go a miss.

    My favourite themes of choice are MatroDark and OfficeBlack :cool:

    That's all really...

    Oh BTW I ABSOLUTELY LOVE THE COLOR PICKER ;):D:cool: and the way it automatically creates the following to the clipboard FX.Colors.From32Bit(0xFFFF0000).
     
    Last edited: May 1, 2015
  3. thedesolatesoul

    thedesolatesoul Expert Licensed User

    Please also custom shortcuts!
     
    JTmartins, Peter Simpson and moster67 like this.
  4. moster67

    moster67 Expert Licensed User

    Yes, I can confirm what Daestrum wrote.

    One other thing. There is a layout misalignment in the Paths Configuration screen (see below screen-shot). Maybe the encircled button should be moved further down so it aligns better with the textbox on the left. Nothing important - just thought I should I mention it.

    b4j.jpg
     
  5. sorex

    sorex Expert Licensed User

    unfortunately not. I tried without virus scanner, after defragging etc and it still needs 12-15 seconds to open it and another 12-15 for the designer.

    b4a needs 6 seconds and designer is instant, but the designer is a totally different matter.

    if it only takes longer to open it (B4A/B4i) and the rest works at the same speed or faster then I can live with it ;)

    I must say that the autocomplete is a lot better/easier now.
     
  6. Toley

    Toley Active Member Licensed User

    I really like the new IDE but the splash screen (enormous B4J) don't look very serious. I hope it will be replaced on the final release.
     
  7. Bob Coleman

    Bob Coleman New Member Licensed User

    I liked it. But everyone is different.
     
  8. Erel

    Erel Administrator Staff Member Licensed User

    WPF applications are slower to start as more libraries are loaded at runtime. On my desktop computer it takes 4-5 seconds to start. On a slower computer it will take longer. There is nothing that can be done about it.
    B4J designer shouldn't really be discussed in this thread as it is a third party designer and it is exactly the same one with the same behavior as in previous version.

    Thank you. Please post any such issue you see.

    I see it too. It will be fixed.

    The state is determined based on the first line. If there is a comment in this line then it will uncomment all lines and vice versa. This is a feature "borrowed" from Eclipse which I think is nice as in most cases you either want to comment uncomment lines or uncomment commented lines.

    This keyboard shortcut is indeed a problematic key. It is call OemQuote. On the computers I tested it the correct natural key was handled ('). It will be possible in the future to change the shortcuts (the IDE is built for this, only the UI is missing).

    Thank you all for your feedback :)
     
    Jmu5667 likes this.
  9. Daestrum

    Daestrum Well-Known Member Licensed User

    After a day trying the new IDE, and only finding one bug and one minor niggle (font colour for java, which was easily sorted), I must congratulate your Alpha tester(s) and you Erel on a very good IDE replacement.
     
    Erel likes this.
  10. rwblinn

    rwblinn Well-Known Member Licensed User

    In ONE sentence = "Got USED to the new IDE in 5 min > can not work withOUT IT anymore!" :)

    High Appreciate your work and a very Well Done
     
    Last edited: May 1, 2015
    Erel and swissmade like this.
  11. swissmade

    swissmade Active Member Licensed User

    I get the same problem here with F3 Search
     
  12. aeric

    aeric Active Member Licensed User

    I am wondering this Beta version supports Additional Libraries? I just installed this beta and tried out Rob's example
    12. Open and load MS Access Database records
    http://www.rwblinn.de/b4j/b4jhowto/examples/b4jhowtomsaccess.zip

    It prompt me an error cannot find the "ucanaccess" library. I have tried to move the related jar files to Libraries folder but the error still persist.

    B4J-Beta3.png

    B4J-Beta3-add-lib.png

    Edit:
    Sorry, is my bad. I just realized I didn't update the version of the libraries in Project Attributes. It compiled successfully now. :)

    Code:
    #Region  Project Attributes
        
    #MainFormWidth: 600
        
    #MainFormHeight: 400
        
    ' SQLite driver                             
          #AdditionalJar: ucanaccess-2.0.9.5.jar
        
    #AdditionalJar: hsqldb.jar
        
    #AdditionalJar: jackcess-2.1.0.jar
        
    #AdditionalJar: commons-logging-1.1.1.jar
        
    #AdditionalJar: commons-lang-2.6.jar
    #End Region
     
    Last edited: May 1, 2015
  13. thedesolatesoul

    thedesolatesoul Expert Licensed User

    Because it is looking for ucanaccess-2.0.2.jar and you have ucanaccess-2.0.9.5.jar.
    Dont blame the software! ;)
     
    DonManfred likes this.
  14. DonManfred

    DonManfred Expert Licensed User

    it cant find ucanaccess-2.0.9.2
    In the libs dir you have an file ucanaccess-2.0.9.5.jar
    Update the dependson directive in the libraries XML file or install v2.0.9.2
     
  15. thedesolatesoul

    thedesolatesoul Expert Licensed User

    dude, are you my clone?
     
    aeric likes this.
  16. DonManfred

    DonManfred Expert Licensed User

    Damned! How did you find out?
     
    Peter Simpson likes this.
  17. thedesolatesoul

    thedesolatesoul Expert Licensed User

    I put my hand through a mirror and it disintegrated!
     
    Peter Simpson and DonManfred like this.
  18. aeric

    aeric Active Member Licensed User

  19. ShaneG30

    ShaneG30 Well-Known Member Licensed User

    I'm receiving an error message.

    "An error occurred.
    Error loading ini"
     
  20. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread for this and provide more information (windows version, VM?, what happens after this error message,...).
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice