Bug? Design and List CustomView B4A 7.80

MarcoRome

Expert
Licensed User
I noticed this problem in design ( B4A 7.80 )
If i open the design i can't see the list of CustomView, even having them.
To see the list of CustomView i have to open the designer for the first time, reopen the designer and answer the following question


upload_2018-1-14_15-24-44.png


with NO.
Look also movie:


Thank you
 

LucaMs

Expert
Licensed User
but do you have a second instance of the Designer open? If so, I think it is not a bug.

P.S. I watched your video now, it happens on the second opening and it should show the msg only if there is a second instance open.
 

Erel

Administrator
Staff member
Licensed User
My guess is that the IDE hasn't yet completed to analyze the project when you first opened the designer.

The custom views list is updated whenever the designer window becomes focused.
Try this:
1. Open the designer.
2. Click on the code editor.
3. Wait a few seconds.
4. Click on the designer window again.

Is the list now populated?
 

MarcoRome

Expert
Licensed User
but do you have a second instance of the Designer open? If so, I think it is not a bug.

P.S. I watched your video now, it happens on the second opening and it should show the msg only if there is a second instance open.
Hi Luca, isnt so, or you have 1 instance or 2 don change.
 

MarcoRome

Expert
Licensed User
My guess is that the IDE hasn't yet completed to analyze the project when you first opened the designer.

The custom views list is updated whenever the designer window becomes focused.
Try this:
1. Open the designer.
2. Click on the code editor.
3. Wait a few seconds.
4. Click on the designer window again.

Is the list now populated?
Hi Erel, If i follow the steps indicated by you, it works, but i have to move inside the code of the ide and not the desginer. Look movie

 

rscheel

Well-Known Member
Licensed User
The same thing happens to me, I thought it was just me but I see that it is not like that.
 
Top