Android Question [SOLVED]Emulator "Installing file to device. Error"


Licensed User
Really strange. Up till now the emulator was working fine (6in_Phone_Platform24_default). Now I get this error appearing:

B4A Version: 9.00
Parsing code. (0.01s)
Building folders structure. (0.03s)
Compiling code. (0.02s)
Compiling layouts code. (0.00s)
Organizing libraries. (0.00s)
Generating R file. (0.00s)
Compiling generated Java code. (0.00s)
Convert byte code - optimized dex. (0.71s)
Packaging files. (0.22s)
Copying libraries resources (0.00s)
Signing package file (debug key). (0.81s)
ZipAlign file. (0.04s)
Installing file to device. Error

Despite the error I can still use my app in the emulator as release version, but not in debug mode (doesn't load).
My app works fine on my own smartphone (both release and debug modes, without "Error" appearing) using B4A bridge (but then I can't test different screens).

Same thing happens when I try other example apps, so it's definitely the emulator and not my app.
I've tried reinstalling the SDK, moving it to a different directory, using different iso's, nothing helps.
I really don't want to try reinstalling B4A (I've read that doesn't help).
Any one had this problem and solved it? Thanks