Beta [B4X] BETAs: B4J v7.80, B4A v.9.50 and B4i v6.00

Discussion in 'Android Questions' started by Erel, Sep 2, 2019.

  1. Erel

    Erel Administrator Staff Member Licensed User

    The three tools are being updated together. This update adds support for copying and pasting layouts between the three platforms. This is an important feature that will make it simpler to build cross platform applications.

    Improvements:

    • Support for copying and pasting controls between the platforms:

      [​IMG]

    • Ctrl + Click in the designer script to select the control.
    • Anchors checker: https://www.b4x.com/android/forum/threads/new-feature-anchors-checker.108805/
    • Generate B4XViews from the designer. Also supports changing the type of already declared variables.
    • Improved tool tips, add views from the views tree and other small improvements and bug fixes in the designer.
    • Empty lines will not be copied to the clipboard.
    • Regions are listed in the subs list:

      [​IMG]

    B4A only improvements:
    • Automatic foreground mode: better handling of several edge cases.
    • B4A Sdk Manager: temp folder is explicitly set by the IDE and fixes related to temporary resources cleaning.
    • Visual designer: Color property now includes the alpha channel. Simpler to use and behaves the same as in B4i and B4J.
    • New designer version. You will be asked to install it when B4A-Bridge connects.
    • FirebaseAdMob v1.60 - There are new requirements. See this post: https://www.b4x.com/android/forum/threads/firebaseadmob-v1-6.108552/#content
    • FirebaseAnalytics v1.11 - Includes the manifest definitions for FirebaseDatabase.

    B4J beta download link: http://www.b4x.com/b4j/files/beta.exe
    B4A download link: mail will be sent today, to developers eligible for free upgrade.
    B4i download link: mail will be sent to developers eligible for free upgrade.
     
    Last edited: Sep 4, 2019
  2. Peter Simpson

    Peter Simpson Expert Licensed User

    Thank you @Erel for the betas, I'm on it with B4J and eagerly waiting for my B4A email :)
     
    Cableguy and Erel like this.
  3. MarcoRome

    MarcoRome Expert Licensed User

  4. LucaMs

    LucaMs Expert Licensed User

  5. David Meier

    David Meier Member Licensed User

    Hi Erel

    Great, thanks a lot!
     
  6. Jmu5667

    Jmu5667 Well-Known Member Licensed User

    [​IMG]
     
    LucaMs likes this.
  7. LucaMs

    LucaMs Expert Licensed User

    "Tomorrow" (or already "today"?) B4X will become the best cross-platform development tool in existence!

    And we'll can say: "We were there!"
     
    Jack Cole, Jorge M A, Erel and 4 others like this.
  8. jeffwu-00

    jeffwu-00 New Member Licensed User

    Hi Erel,
    Very good update, very excited. Thanks a lot.
    :):):)







    社群
     
  9. Cableguy

    Cableguy Expert Licensed User

    Another small step for @Erel, yet another huge improvement for mankind!
     
    Filippo, Jorge M A and Johan Hormaza like this.
  10. amykonio

    amykonio Member Licensed User

    Wow..
    I don't remember if this happened in the past. A beta simoultaneously for b4j, b4i and b4x.

    Well done Erel.
    My respect.

    Andrea's.
     
  11. Johan Hormaza

    Johan Hormaza Active Member Licensed User

    Good job EREL .... You're Flying!
     
  12. cimperia

    cimperia Active Member Licensed User

    B4A: SDK and AVD Managers won't run, i.e. I click on the relevant option and nothing happens at all.

    I'm running windows 10.
     
    Last edited: Sep 2, 2019
  13. tucano2000

    tucano2000 Active Member Licensed User

  14. itgirl

    itgirl Active Member Licensed User

    Tray to change the jdk you use i had similar issue with v11 none of jars worked i had to run them through cmd only
     
  15. kisoft

    kisoft Active Member Licensed User

  16. Erel

    Erel Administrator Staff Member Licensed User

    Please start a new thread for this.

    Which version of Java are you using (Tools - Configure Paths)? If Java 11 then make sure to use the Java 11 downloaded from: https://www.b4x.com/b4a.html
     
  17. vvg

    vvg Member Licensed User

    :)great...as always.....
     
  18. cimperia

    cimperia Active Member Licensed User

    Yes, that's the one I'm using. The error might be related to the bug I reported here.

    I tried with Oracle JDK 8 as well with the same result.

    OK, to be sure I reinstalled all the software required and set the paths as per the Online instructions. I first ran B4A 9.30 and I got the bug I reported above. I then installed the B4A 9.5 beta and nothing happens. I suspect it has to do with the bug I reported. Just speculation, of course as there's no log I can check.

    Build Tools: 27.0.1

    upload_2019-9-3_10-20-49.png
     
  19. Erel

    Erel Administrator Staff Member Licensed User

  20. arastoo

    arastoo Active Member Licensed User

    Hi Erel
    Great, thanks a lot!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice