Android Question AVDs not running anymore...

Peter Simpson

Expert
Licensed User
Hiya all,
For the last coupe of months I've not been able to get my Android emulator to run which I start using B4A > Tools > Run AVD manager. I'm presuming that it was an Android SDK update that has been installed in one of the updates. I just went to start the AVD one day and I noticed that there were no virtual devices installed, so I installed a couple and I've not been able to get any of them working. The strange thing is that all the previous AVDs worked 100% perfectly fine.

AVDs get stuck on this screen.
Emulator.jpg


Thank you...
 

Peter Simpson

Expert
Licensed User
Okay, I deleted the AVDs from AVD Manager and I also deleted the B4AEmulator folder. I recreated a new AVD which in turn recreated the B4AEmulator folder, I ran the newly created AVD and I'm still having the exact same problem as the screenshot above in my first post. Basically the word 'android' constantly does it's animating fading effect from left to right without stopping, but the AVD never actually starts the Android GUI, I've been waiting for well over 15 minutes whilst doing other things.
 

AnandGupta

Well-Known Member
Licensed User
I got similar situation few weeks earlier. I had B4A 8.5 installed then.

I did the below, AVD is Ok now and I am happy,
  1. Installed latest B4A 8.8, it the best IDE I must say after using it for last few weeks :)
  2. Run AVD, it gave list to install and I obeyed them.
  3. Run ADB just to be on safe side as it was mentioned in below status of AVD
  4. Starting the shown AVD 4in.. did not start
  5. Created a new 6in.. with version 24 (default).
  6. It starts and runs smooth.
  7. No problem till date
  8. Now I am mostly using emulator to check my development and connecting to mobile at final stage
  9. Having touch screen laptop is helping a lot as I can scroll, click on the emulator mobile.
Regards,

Anand
 

rbghongade

Active Member
Licensed User
Facing the same problem as Peter. SDK 24 based emulator works fine, but SDK 28 just gets stuck at ANDROID logo!
 

Shelby

Active Member
Licensed User
Just for some encouragement, my B4A built-in emulator works fine for me with my 64 bit windows OS. Admittedly my App is very simple. It worked with version 8.50 and now with 8.80. I too had configuration problems and just kept trying. I found that the manager configuration was my final problem to solve before reaching success.
 
Last edited:

Peter Simpson

Expert
Licensed User
B4A AVD Manager previously worked 100% perfect on all the AVDs that I created, that includes those creating using fine on Platform 28, also I've been using V3.30 since last year. All I know is that a few weeks ago everything was working fine, and now it's not. The last time I used the emulator was about 6 weeks ago. I'm going to presume that it has something to do with an Android SDK update, as that wouldn't be the first time updates has messed something up.

Now I'm getting this every time I start the B4A AVD manager.
Untitled-2.png


I've not spent that much time on this issue as I have plenty of devices to create and test on, plus I'm currently working on a clients warehouse application.

It would be nice to get the AVDs working again at some point.
 
Top